Linux Calibre 4.9.1 - Crash to desktop

Bug #1861741 reported by Steve Healey on 2020-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Version: 4.9.1
OS: Linux

Steps to reproduce:

1) Start calibre
2) Click Preferences
3) Choose to change behaviour
4) Click Output options
5) calibre disappears

Running from command prompt adds following messages after crash:

free(): invalid pointer
Aborted (core dumped)

I renamed "Calibre Library" and '.config/calibre" and was able to reproduce the same error using the same above steps with the blank configuration and library.

I do not provide support for people using distro provided packages. If you are using a distro provided package, uninstall it and install the official calibre binary from https://calibre-ebook.com/download_linux and if you can reproduce the bug with that, re-open the ticket. Of course, if you are already using the official binary, apologies and feel free to re-open the ticket immediately :)

 status invalid

Changed in calibre:
status: New → Invalid
Steve Healey (dolamant) wrote :

Sorry, I should have mentioned that I was using the official version. Thank you!

Changed in calibre:
status: Invalid → New
Kovid Goyal (kovid) wrote :

run calibre as

calibre-debug -g

and post the output from the terminal after the crash

Here is the output produced by the following command:

script -c "calibre-debug -g" Calibre-output

On Mon, Feb 3, 2020 at 9:55 PM Kovid Goyal <email address hidden>
wrote:

> run calibre as
>
> calibre-debug -g
>
> and post the output from the terminal after the crash
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1861741
>
> Title:
> Linux Calibre 4.9.1 - Crash to desktop
>
> Status in calibre:
> New
>
> Bug description:
> Version: 4.9.1
> OS: Linux
>
> Steps to reproduce:
>
> 1) Start calibre
> 2) Click Preferences
> 3) Choose to change behaviour
> 4) Click Output options
> 5) calibre disappears
>
> Running from command prompt adds following messages after crash:
>
> free(): invalid pointer
> Aborted (core dumped)
>
> I renamed "Calibre Library" and '.config/calibre" and was able to
> reproduce the same error using the same above steps with the blank
> configuration and library.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1861741/+subscriptions
>

Kovid Goyal (kovid) wrote :

Next try producing a backtrace

echo bt | coredumpctl gdb

assuminf your distro uses systemd otherwise you will need to find out how to create backtraces for it.

Steve Healey (dolamant) wrote :
  • backtrace Edit (23.4 KiB, application/octet-stream; name=backtrace)

The command in your response, just produced the message "No coredump
found.", even though my distro does use systemd. I figured out how to
generate the coredump file and then using gdb created a backtrace fle,
Thank you for your patience with me!

On Wed, Feb 5, 2020 at 5:15 PM Kovid Goyal <email address hidden>
wrote:

> Next try producing a backtrace
>
> echo bt | coredumpctl gdb
>
> assuminf your distro uses systemd otherwise you will need to find out
> how to create backtraces for it.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1861741
>
> Title:
> Linux Calibre 4.9.1 - Crash to desktop
>
> Status in calibre:
> New
>
> Bug description:
> Version: 4.9.1
> OS: Linux
>
> Steps to reproduce:
>
> 1) Start calibre
> 2) Click Preferences
> 3) Choose to change behaviour
> 4) Click Output options
> 5) calibre disappears
>
> Running from command prompt adds following messages after crash:
>
> free(): invalid pointer
> Aborted (core dumped)
>
> I renamed "Calibre Library" and '.config/calibre" and was able to
> reproduce the same error using the same above steps with the blank
> configuration and library.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1861741/+subscriptions
>

From the backtrace, the crash is happening in your systems Qt 5 CUPS
printer plugin. You can confirm by renaming the file /usr/lib64/qt5/plugins/printsupport/libcupsprintersupport.so

 status invalid

Changed in calibre:
status: New → Invalid
  • backtrace2 Edit (23.8 KiB, application/octet-stream; name=backtrace2)

I renamed the above .so file and it still core dumps. Here is the backtrace
of the second core dump.

On Wed, Feb 5, 2020 at 9:05 PM Kovid Goyal <email address hidden>
wrote:

> >From the backtrace, the crash is happening in your systems Qt 5 CUPS
> printer plugin. You can confirm by renaming the file
> /usr/lib64/qt5/plugins/printsupport/libcupsprintersupport.so
>
> status invalid
>
> ** Changed in: calibre
> Status: New => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1861741
>
> Title:
> Linux Calibre 4.9.1 - Crash to desktop
>
> Status in calibre:
> Invalid
>
> Bug description:
> Version: 4.9.1
> OS: Linux
>
> Steps to reproduce:
>
> 1) Start calibre
> 2) Click Preferences
> 3) Choose to change behaviour
> 4) Click Output options
> 5) calibre disappears
>
> Running from command prompt adds following messages after crash:
>
> free(): invalid pointer
> Aborted (core dumped)
>
> I renamed "Calibre Library" and '.config/calibre" and was able to
> reproduce the same error using the same above steps with the blank
> configuration and library.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1861741/+subscriptions
>

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released

Awesome, thanks!

On Wed, Feb 5, 2020, 9:25 PM Kovid Goyal <email address hidden> wrote:

> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every alternate Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Invalid => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1861741
>
> Title:
> Linux Calibre 4.9.1 - Crash to desktop
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Version: 4.9.1
> OS: Linux
>
> Steps to reproduce:
>
> 1) Start calibre
> 2) Click Preferences
> 3) Choose to change behaviour
> 4) Click Output options
> 5) calibre disappears
>
> Running from command prompt adds following messages after crash:
>
> free(): invalid pointer
> Aborted (core dumped)
>
> I renamed "Calibre Library" and '.config/calibre" and was able to
> reproduce the same error using the same above steps with the blank
> configuration and library.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1861741/+subscriptions
>

Kovid Goyal (kovid) wrote :

Its loading the renamed file, move it out of that directory completely.

Moving the file out of the directory, solved the crash! Thank you for all
of your help!

On Wed, Feb 5, 2020 at 9:35 PM Kovid Goyal <email address hidden>
wrote:

> Its loading the renamed file, move it out of that directory completely.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1861741
>
> Title:
> Linux Calibre 4.9.1 - Crash to desktop
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Version: 4.9.1
> OS: Linux
>
> Steps to reproduce:
>
> 1) Start calibre
> 2) Click Preferences
> 3) Choose to change behaviour
> 4) Click Output options
> 5) calibre disappears
>
> Running from command prompt adds following messages after crash:
>
> free(): invalid pointer
> Aborted (core dumped)
>
> I renamed "Calibre Library" and '.config/calibre" and was able to
> reproduce the same error using the same above steps with the blank
> configuration and library.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1861741/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers