Viewing Text Files Creates an Index File

Bug #1853232 reported by James Aeschliman on 2019-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I have been using the e-book viewer of Calibre to read test files for several years. Version 4 now creates an "index#" file for every text file I read. The "index#" file (opens with Firefox) turns out to be just a copy of the text file I have just read. After reading several text files I have several "index#" files that I then have to delete. I am using Version 4.3 of Calibre and my operating system is Windows 10. I need a way to disable this function. If there is not a way to disable this function in the existing version, please create an enhancement to do this.

What index# file? Where is it created? I see no index# files when
opening txt files with the viewer.

Where are these files created? FWIW, I do not have any such files
created for me when using a different operating system (Linux). So I
don't think that calibre is fundamentally creating such files, and it
sounds like if anything it will have something to do with the way
calibre interacts with Windows.

I have a large number of text files in various subdirectories. If I use the Viewer to view several text files, something is creating a Firefox HTML files in the same subdirectory where the text file is located. As an example, if I view three text files I will then find three "index#" files (index1, index2, and index3). This did not happen before the Viewer was changed in Version 4 of Calibre. That is why I believe the problem is related to Calibre I am running the latest version of Windows10 Home and my default web browser is the latest version of Firefox.

________________________________
From: <email address hidden> <email address hidden> on behalf of Kovid Goyal <email address hidden>
Sent: Tuesday, November 19, 2019 8:47 PM
To: <email address hidden> <email address hidden>
Subject: [Bug 1853232] Re: calibre bug 1853232

What index# file? Where is it created? I see no index# files when
opening txt files with the viewer.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1853232

Title:
  Viewing Text Files Creates an Index File

Status in calibre:
  New

Bug description:
  I have been using the e-book viewer of Calibre to read test files for
  several years. Version 4 now creates an "index#" file for every text
  file I read. The "index#" file (opens with Firefox) turns out to be
  just a copy of the text file I have just read. After reading several
  text files I have several "index#" files that I then have to delete.
  I am using Version 4.3 of Calibre and my operating system is Windows
  10. I need a way to disable this function. If there is not a way to
  disable this function in the existing version, please create an
  enhancement to do this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1853232/+subscriptions

James Aeschliman (princejames) wrote :

Additional Information

The "index#" is created as the Viewer opens the text file.

I have attached screenshots showing the subdirectory before and after opening the text file with the viewer.

________________________________
From: <email address hidden> <email address hidden> on behalf of Kovid Goyal <email address hidden>
Sent: Tuesday, November 19, 2019 8:47 PM
To: <email address hidden> <email address hidden>
Subject: [Bug 1853232] Re: calibre bug 1853232

What index# file? Where is it created? I see no index# files when
opening txt files with the viewer.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1853232

Title:
  Viewing Text Files Creates an Index File

Status in calibre:
  New

Bug description:
  I have been using the e-book viewer of Calibre to read test files for
  several years. Version 4 now creates an "index#" file for every text
  file I read. The "index#" file (opens with Firefox) turns out to be
  just a copy of the text file I have just read. After reading several
  text files I have several "index#" files that I then have to delete.
  I am using Version 4.3 of Calibre and my operating system is Windows
  10. I need a way to disable this function. If there is not a way to
  disable this function in the existing version, please create an
  enhancement to do this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1853232/+subscriptions

James Aeschliman (princejames) wrote :

Additional Information #2

The index# file problem happens when I run the Viewer program as a standalone application, i.e., I click on the e-book viewer 64 bit icon to open the Viewer and open the text file from there. It does not happen if I open the Calibre e-book Management program. load the text file into the Library, and then click on View to open the text file. I hope this helps.

________________________________
From: <email address hidden> <email address hidden> on behalf of Kovid Goyal <email address hidden>
Sent: Tuesday, November 19, 2019 8:47 PM
To: <email address hidden> <email address hidden>
Subject: [Bug 1853232] Re: calibre bug 1853232

What index# file? Where is it created? I see no index# files when
opening txt files with the viewer.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1853232

Title:
  Viewing Text Files Creates an Index File

Status in calibre:
  New

Bug description:
  I have been using the e-book viewer of Calibre to read test files for
  several years. Version 4 now creates an "index#" file for every text
  file I read. The "index#" file (opens with Firefox) turns out to be
  just a copy of the text file I have just read. After reading several
  text files I have several "index#" files that I then have to delete.
  I am using Version 4.3 of Calibre and my operating system is Windows
  10. I need a way to disable this function. If there is not a way to
  disable this function in the existing version, please create an
  enhancement to do this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1853232/+subscriptions

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers