Viewer problems in full-screen mode

Bug #1850845 reported by Jernej Simončič on 2019-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When using the viewer in full-screen mode, the screen often blinks (sometimes for no reason I can see, I can sometimes get it to blink when I move the mouse pointer between the text area and the margin, opening or dismissing the menu makes the screen blink almost every time, as does switching to or from the viewer - for some reason, Alt+Tab dialog also isn't visible when in full-screen mode and Calibre Viewer is the active window; moving through Preferences also often makes the screen blink).

Additionally, mousewheel scrolling only works when mouse pointer is above the text area - if I move it outside, it's ignored - this is a regression from Calibre 3.

Also, Preferences → Page layout → "Change maximum screen area (in pixels) used to display text" option is misleading, since the setting definitely isn't in pixels, but instead appears to be scaled by screen DPI factor (I'm using a high-DPI display).

OS: Windows 10 1903 x64
Calibre: 4.2 64-bit

One more problem: if you switch away from the viewer (in full-screen mode), it'll change whatever it's showing with something it was showing earlier (this also happens if I move focus to a window on another monitor, just leaving the viewer where it was, with no other window obscuring it).

The display issues/alt-tab issues are caused by incompatibilities
between Qt WebEngine and some GPU/multi-monitor setups. Other than
recommending that you upgrade your GPU drivers not much I can do about
it.

The scroll wheel not working on margins will be fixed in the next
release.

As for pixels, they are CSS pixels, which are not physical pixels. You
will have to take it up with the HTML standards committees as to why
they chose to make the pixel a virtual unit.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released

I'm using nvidia GTX470 with driver version 440.97, but even upgrading to 441.08 (which is the latest) doesn't help.

Does the viewer switch to actual full-screen mode like games, and if it does, can this be disabled and instead it just work in borderless mode?

Re pixels: if it's CSS, I think that's scaled by current DPI/96 (at least on Windows; no idea about other OSes), so maybe divide the entered number by that (or change the label to not say pixels)? Also, the setting seems to be randomly ignored, and I have to restart the viewer a few times to not get text spanning the full width of my screen.

Full screen switching mode is not controlled by calibre code, it's done
by Qt and that in turn delegates to Blink.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers