text after HTML comment in epub is not displayed

Bug #1846875 reported by korak on 2019-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

The Ebook Viewer of Calibre 4.0 does not render text after a HTML comment.

For example:
<p>
some text before the formula <img alt="images" src="../images/img1.png"/><!--<m:math display="inline" overflow="scroll" xmlns:m="http://www.w3.org/1998/Math/MathML" xmlns:xlink="http://www.w3.org/1999/xlink"><!- -<m:?ePubPI imagename="img1.png"?>- -><m:mrow><m:msup><m:mi mathvariant="normal">t</m:mi><m:mo>&#8242;</m:mo></m:msup></m:mrow></m:math>--> some text after the formula.
</p>
Here only the text "some text before the formula" is displayed the text after the comment is not visible.

I have attached a minimal document to reproduce this issue. It works fine with Version 3.48 on Arch Linux.

Thanks for this great piece of software.

korak (korak7) wrote :

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
korak (korak7) wrote :

I can confirm that the problem is fixed in 4.1. For others: note that you have to reload the book within the viewer as noted in the change log (right click in viewer, reload).
Thanks @kovid!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers