ebook editor crashes out when scrolling

Bug #1846760 reported by bassman1961 on 2019-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Just updated to 4.0.. Everytime I try to edit an ebook, it crashes out. Seems related to scrolling... Happens EVERYTIME. I haven't been able to edit anything since installing.
I am using Ubuntu 19.04 (stock install) Acer Predator laptop, gobs of memory.. Never had any problems until 4.0

Going back to last version until fixed. Keep up the good work. Love this program.

Cant replicate on my Arch linux machine or in my ubuntu VM, does it
happen for all books? Try opening the calibre quick start guide as
atest. Can you post some set of steps to get it to crash. And a
backtrace from the crash (not sure how you get backtraces in ubuntu) but
something like

echo bt | coredumpctl gdb

 status incomplete

Changed in calibre:
status: New → Incomplete
To Do (entodoays) wrote :

I tried opening the Calibre user manual and I encountered the same error but much less frequently. It seems the error comes mostly when reading books containing a large number of small files, like the sample book I attached. When scrolling a scroll bar briefly appears and, I'm not sure, but it seems the problem occurs more frequently when the mouse pointer is positioned in that area of the page.

How to get the error. I simply continued scrolling with trackpad double-finger gesture until the viewer got stuck on the message mentioned above. The issue doesn't happen always and although it happened to me immediately when I first opened the file, it seems that has become less frequent on the same file. Also if I press the Esc key when it gets stuck, the viewer becomes responsive again, so it is not a fully-fledged crash.

I'm using Gnome on Wayland if that has any weight.

I tried looking at the logs, but didn't notice anything Calibre related. Running from the terminal doesn't give any error messages.

I'll try to get backtraces. I've never done that, but I'll find out when I have time.

Kovid Goyal (kovid) wrote :

This is about the editor not the viewer, for th eviewer see https://bugs.launchpad.net/calibre/+bug/1846751

To Do (entodoays) wrote :

I just now realised that I wrote editor instead of viewer. Sorry.

bassman1961 (daveg123) wrote :

Ok, Some additional info...

Had to go back to previous version to do some edits, then reinstalled 4.0. The problem returned.
Happens everytime I try to edit ANY book, and I tried a lot! It creates and "Ubuntu problem report" I saved some text from the crash log, and will attach it...

The Ubuntu rash report was 34MB long, I omitted a lot of the mundane as well as the bas64 core dump, I hope there is something usable in this. Anything else I can do to get more info for you guys?

-DG

Kovid Goyal (kovid) wrote :

That tells me the crash is happening inside the stringProperty function, but calibre itself does not call that function, ever. So it is something internal to Qt. If you can get a proper backtrace that might help narrow down the cause. I dont use ubuntu so not sure of the procedure for getting backtraces there, but on systemd based distros, something like:

echo bt | coredumpctl gdb

bassman1961 (daveg123) wrote :

Just a quick update, after the new release (4.1) The editor no longer crashes! I do not know what changed, but the whole package now works flawlessly! Thank you for such a great program!

Kovid Goyal (kovid) wrote :

Strange, I changed exactly nothing in the editor in 4.1.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers