"articles" for sort strings do not working/save

Bug #1834329 reported by Danilo Pedro da Silva on 2019-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Danilo Pedro da Silva

Bug Description

Do not work when I try to edit the tweak "Set the list of words considered to be "articles" for sort strings (ID: per_language_title_sort_articles)".

If I try to put default_language_for_title_sort or title_sort_articles for exemple, not saved.

If I try to edit, some times save but do not work.

The only words that work are "A, An, As, The" no more.

I have been trying make do words like article. (I'm use portuguese language)

I need this words like articles "A, As, O, Os, Em, Um, Uns, Uma, Umas, Da, Das, De, Do, Dos" and some prepositions too.

I think if the tweak work, I can edit on my own.

Current infomation:
Calibre version 3.44 (but don't work in older versions)
OS Windows 10 (but I try on Manjaro and Ubuntu)

Sorry for my english.

Look that images for exemple.

Config that I make: https://ibb.co/1sytHTL
https://ibb.co/znmhDH4
https://ibb.co/yF4G9w2

I click in "Apply changes to this tweak" and "Apply" and restart but don't save. If is not a bug sorry.

description: updated
description: updated

Does not work where? Remember that the book has to have its language set
to portuguese for those articles to be applied.

 status incomplete

Changed in calibre:
status: New → Incomplete
description: updated
Kovid Goyal (kovid) wrote :

You hve to first click the button labelled "Apply changes to this tweak"
and then the overall "Apply" button to have the changes to the tweaks
saved.

 status invalid

Changed in calibre:
status: Incomplete → Invalid

I click in "Apply changes to this tweak" and "Apply" and restart but don't save. If is not a bug sorry.

description: updated

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
Changed in calibre:
assignee: nobody → Danilo Pedro da Silva (danilopedrods)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers