Comment 4 for bug 1830101

Lukas Ahrenberg (lukas-u) wrote :

Hi David,

I've also got an old and more or less unpatched kobo touch (firmware 1.9.17, dbversion 36) sitting here. I ran into a similar problem after updating calibre some time ago. My issue was not with the Language column, but with ISBN however.

Looking into that particular issue today, the I noted that the ISBN column is added to the query already from dbversion 33 in kobo/driver.py, while it seems like it isn't supported on v. 36 at least.

I added a separate if-case checking dbversion >= 37 and moved the ISBN column handling there from the dbversion >= 33 case in kobo/driver.py. This solved the issue for me. A patch is attached if you are interested.

N.b: I do not know if dbversion 37 actually has an ISBN column, I chose that version as it is one above the one I have on my device.

Best,

.Lukas

 Possibly relevant debug output:

DEBUG: 0.0 Version of driver: (2, 5, 1) Has kepubs: True
DEBUG: 0.0 Version of firmware: (1, 9, 17) Has kepubs: True
DEBUG: 1.1 Database Version: 36