special signs are ignored in catalog

Bug #1826127 reported by Katja on 2019-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

this is new since Version 3.41

independent wheter creating a catalog with Standard py or conf or my own
a) "&" is shown as "&"
happens e.g. in the author Name and in title
but it is also shown correct at other places

b) middledot is shown as "·"
happens in Title section. The middledot is not added by me. In the default layout the author is shown with a middot in the title section.

Reproduce:
- create a catalog in epub Format with author, title, genre
- search for "&amp" and "&middot"

Katja (katjawy) wrote :

@kovidgoyal,
could you please have a look into this.

Maybe I can replace the middot by something different. But I cannot fix the issue with «&» as this happens only with author and title i.e. not static, more logic.

It seems there is a different character table used, since last updates.
What are your thoughts on that?

I will look into it when I have a moment.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers