Bug when copying an existing book from one library to another

Bug #1816224 reported by Werner Arts on 2019-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

It warns, but when saying Yes, the imported book has no content and no metadata in the new library

Werner Arts (w-arts) on 2019-02-16
description: updated

I cannot reproduce. What version of calibre is this on what operating
system? And what warning are you talking about?

 status incomplete

Changed in calibre:
status: New → Incomplete

Operating system: Windows10/64 Pro

I have some libraries:
Bibliothek with app 10.700 books

New with 3 books

Which i want to move into Bibliothek and i got this message

When pressing OK the result in Bibliothek is

Book 2 and 3 are moved correct, but book 1 has no content and the folder
contains only "metadata.opf" (attached)

Regards, Werner Arts

Am 16.02.2019 um 19:02 schrieb Kovid Goyal:
> I cannot reproduce. What version of calibre is this on what operating
> system? And what warning are you talking about?
>
> status incomplete
>
> ** Changed in: calibre
> Status: New => Incomplete
>

Kovid Goyal (kovid) wrote :

What settings do you have for Preferences->Adding actions

Kovid Goyal (kovid) wrote :

Sorry, I meant Preferences->Adding books->adding actions

No Rules - they are empty

This i did never change since app 2013

Regards, Werner

Am 17.02.2019 um 05:25 schrieb Kovid Goyal:
> Sorry, I meant Preferences->Adding books->adding actions
>

ashson (ashson) wrote :

I have the same problem.
The error is:

calibre, version 3.39.0
ERROR: Failed to copy some books: Could not copy some books, click "Show Details" for more information.

Failed to copy 52 books, see below for details

Copying: Blood of Others failed, with error:
Traceback (most recent call last):
  File "site-packages\calibre\gui2\actions\copy_to_library.py", line 160, in _doit
  File "site-packages\calibre\gui2\actions\copy_to_library.py", line 175, in do_one
  File "site-packages\calibre\db\copy_to_library.py", line 109, in copy_one_book
  File "site-packages\calibre\db\copy_to_library.py", line 63, in postprocess_copy
  File "site-packages\calibre\db\cache.py", line 63, in call_func_with_lock
TypeError: set_conversion_options() takes at most 3 arguments (4 given)

The books copy but the error comes up.

Kovid Goyal (kovid) wrote :

That's not the same problem and you can fix it by updating calibre to 3.39.1

Sorry I cannot replicate this on my windows machine either, using the
stepps you described. I am guessing this was caused by the original book
record in the source library missing the files. Try running check
library on it to confirm.

 status invalid

Changed in calibre:
status: Incomplete → Invalid

It happens with each book I did - on every Computer I tried with mirrors
of my "Bibliothek" library (app 10.700 books):
no errors in Database -> no problems found.

The copying (moving) bug started with 3.39.0 and changed in 3.39.1.

3.38 worked correct

My Calibre 3.39.1 is buggy!

Werner Arts

Am 07.03.2019 um 10:09 schrieb Kovid Goyal:
> Sorry I cannot replicate this on my windows machine either, using the
> stepps you described. I am guessing this was caused by the original book
> record in the source library missing the files. Try running check
> library on it to confirm.
>
> status invalid
>
> ** Changed in: calibre
> Status: Incomplete => Invalid
>

Changed in calibre:
status: Invalid → Incomplete

I am going to need some way to re-create your error to help you. Post a
set of systematic steps describing what you are doing. For example:

1) Click on a book
2) Right click and choose Copy to libbrary->library name (delete after
copy)
3) Get a popup notifying of possible duplicates
4) Click add anyway
5) Switch to target library
6) Select newly copied book
7) See that is has no formats in it

In Library "Bibliothek" exists "Adler und Engel" by "Juli Zeh"

This book exists too in library "Neu" - you can see page 2 in Viewer

When doing a Copy and delete to "Bibliothek"

This message appears

In "NEU" "Adler und Engel" vanished
When pressing OK:
"Bibliothek" shows "unbekannt", "unbekannt" no size - only .opf in this
folder

Copying and moving problems started with 3.39.0 - before, all was OK

Regards, Werner Arts

The same behavior is in Calibre Portable

Am 07.03.2019 um 11:16 schrieb Kovid Goyal:
> I am going to need some way to re-create your error to help you. Post a
> set of systematic steps describing what you are doing. For example:
>
> 1) Click on a book
> 2) Right click and choose Copy to libbrary->library name (delete after
> copy)
> 3) Get a popup notifying of possible duplicates
> 4) Click add anyway
> 5) Switch to target library
> 6) Select newly copied book
> 7) See that is has no formats in it
>

Charles Haley (cbhaley) wrote :

Is either library on a network drive, a "non-standard" filesystem, or a folder controlled by a sync program such as Dropbox?

Both libraries (Bibliothek, Neu) in Calibre64-3.19.1 are on drive
C:\Calibre = 1 TB SSD
The (different) libraries in Portable Calibre (on the same computer) are
on drive D: = 4 TB Sata HD.

In Calibre64/PortableCalibre 3.38.1 everything is OK - the copy/move
problems began with 3.39.0

Regards, Werner Arts

Am 07.03.2019 um 14:03 schrieb Charles Haley:
> Is either library on a network drive, a "non-standard" filesystem, or a
> folder controlled by a sync program such as Dropbox?
>

Kovid Goyal (kovid) wrote :

there was indeed a bug in 3.39.0 but it was fixed in 3.39.1

Werner Arts (w-arts) wrote :

When fixing 3.39.0 another copying/moving bug occured - all Versions of
3.38 were OK.

The same problem exists with an mirror of Calibre Portable 3.39 from D:
to a portable (USB3) SSD used on another computer.

File System is NTFS

Regards, Werner Arts

Am 07.03.2019 um 17:29 schrieb Kovid Goyal:
> there was indeed a bug in 3.39.0 but it was fixed in 3.39.1
>

Werner Arts (w-arts) wrote :

Error in line 3 of #15:
3.39 should be 3.39.1
The same problem exists with an mirror of Calibre Portable 3.39.1 from D:
to a portable (USB3) SSD used on another computer.

Werner Arts (w-arts) wrote :

https://mega.nz/#!mRJDFSZJ!PpwoQNHLqvQU_Wr9jeKq_rydR3qLSD8TI0v2hv7OP6U
contains my CalibrePortable.zip with 2 Libraries, each containing the same book from John Schember
Calibre 3.39.1 shows the bug in moving.
If 3.38.1 would be installed, moving is OK

Ah, that allowed me to reproduce th eissue, fix will be in next release.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers