"Remove indents at the beginning of lines" setting removes paragraph breaks in conversion

Bug #1814989 reported by Warren Young on 2019-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

If you enable this setting under Prefs > Input options > TXT input > Remove indents at the beginning of lines then do a conversion from a text format such as Markdown, all of the paragraphs are combined into a single paragraph in the output. This happens with EPUB and MOBI output, at least. You can see the problem in the intermediate HTML file generated, so it'll probably affect anything that uses this HTML intermediary.

Here is a tiny file to test with: https://tangentsoft.com/misc/calibre-para-test.md

The problem is not specific to the input: a very wide swath of the world's Markdown files are likely affected. Certainly all of the hundreds in my Calibre library are.

You'd expect that input to give an EPUB or MOBI file with two paragraphs, but with this setting enabled, you get a single paragraph.

This happens back at least to 3.38.1 to the current release, 3.39.1. It happens on both macOS and Linux, at least.

Further details are in this forum thread: https://www.mobileread.com/forums/showthread.php?p=3807505

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers