ebook-convert does not display bold font when converting from html to pdf on OSX Mojave

Bug #1799750 reported by Brandon Pettit on 2018-10-24
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I just updated to the Mac OSX Mojave update last night and have been using the ebook-convert command to convert html files to pdf. Before the update, all my fonts had the proper regular, italics, and bold displays. After the update, when I would build my files to test, the regular and bold fonts did not appear any different.

Here are the steps to reproduce:
1. Must be on OSX Mojave
2. Create HTML file that displays html formatting options like so:
```
<h1>Introduction</h1>

Hello world, this is my first post.

<h2>This is an H2</h2>
<h3>This is an H3</h3>
<h4>This is an H4</h4>
<h5>This is an H5</h5>

Here is some good <i>italics</i> <br>
Here is some good <em>italics</em> <br>
Here is some good <strong>bold</strong> <br>
Here is some good <b>bold</b> <br>
Here is some good <mark>mark</mark> <br>
Here is some good <small>small</small> <br>
Here is some good <del>delete</del> <br>
Here is some good <ins>inserted</ins> <br>
Here is some good <sub>subscript</sub> <br>
Here is some good <sup>superscript</sup>
```
3. Run ebook-convert file.html file.pdf
4. Check the PDF output to see that the bold is not displaying for either the strong or the b tags.

This is being used for a work project, so the sooner it can be addressed the better. Thanks!

Brandon Pettit (novabran) wrote :

Upgrade calibre, should be fixed already: https://github.com/kovidgoyal/build-calibre/commit/3a421d8bdb0d4394f4c16f9b637f14e613654b83

 status fixreleased

Changed in calibre:
status: New → Fix Released
Brandon Pettit (novabran) wrote :

Hi Kovid,

That's just the problem. I've updated to 3.33.1 when I did these tests. I also don't see that PR in the 3.33.1 changelog.

Is there something I'm missing? Do I need to update the CLI separately or something?

Kovid Goyal (kovid) wrote :

If you've upgraded to 3.33.1 already then that fix is in there. If it isn't working, then I'm afraid I have no idea what the cause is. I suggest using a VM if you need it working immediately.

Brandon Pettit (novabran) wrote :

Hi Kovid,

Thanks for the response. I will be using a VM with linux to do the official build I'm working with, but can you re-open this to investigate this issue when time permits? I really like this tool and the process I'm able to use with it, but I may need to investigate alternative tools if this can't be resolved.

Thanks for your time and attention!
Brandon

Kovid Goyal (kovid) wrote :

This is not an issue in calibre code, so there is not much I can do to
fix it. Hopefully, when calibre moves to using QT 5.12 it will fix
itself, which will happen for calibre 4.0

Kovid Goyal (kovid) on 2018-10-25
Changed in calibre:
status: Fix Released → New
Brandon Pettit (novabran) wrote :

Is there a timeline for calibre 4.0? I'm looking forward to testing that.

Kovid Goyal (kovid) wrote :

Sadly no. There's a good deal going on in my personal life right now that is interfering.

Brandon Pettit (novabran) wrote :

Sorry to hear that, Kovid. I really enjoy calibre, so I hope things turn out well and you are able to continue your good work.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Kovid Goyal (kovid) wrote :

well I found some time to fix this.

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers