Footnote not updating when file split used in editor

Bug #1787892 reported by maxthegold on 2018-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Windows 10 Pro
Calibre 3.29

When editing an epub file that contains footnotes, if you do a file split (single or multiple) the file name in the footnote reference and anchor doesn't change. Footnote reference and anchor are as follows.

<a id="FNanchor_1_1"></a><a href="part0001.html#Footnote_1_1">[1]</a>

<a id="Footnote_1_1"></a><a href="part0001.html#FNanchor_1_1">[1]</a>

Thanks,
    Mark.

description: updated

Attach an ebook file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
maxthegold (markwhsavage) wrote :

Done.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Kovid Goyal
Sent: Monday, 20 August 2018 5:40 PM
To: <email address hidden>
Subject: [Bug 1787892] Re: calibre bug 1787892

Attach an ebook file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

** Changed in: calibre
       Status: New => Incomplete

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1787892

Title:
  Footnote not updating when file split used in editor

Status in calibre:
  Incomplete

Bug description:
  Windows 10 Pro
  Calibre 3.29

  When editing an epub file that contains footnotes, if you do a file
  split (single or multiple) the file name in the footnote reference and
  anchor doesn't change. Footnote reference and anchor are as follows.

  <a id="FNanchor_1_1"></a><a href="part0001.html#Footnote_1_1">[1]</a>

  <a id="Footnote_1_1"></a><a href="part0001.html#FNanchor_1_1">[1]</a>

  Thanks,
      Mark.

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1787892/+subscriptions

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers