wrong tags order in list from DOCX

Bug #1771279 reported by Alberto Garcia on 2018-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre is 3.23.0 for Mac, Word is 2011 (also Mac). Original DOCX also edited in a Windows 7 machine, with Word 2016 (but last edition with 2011 for Mac).

Upon exporting a list, the HMTL tags have an invalid order. Should be

div
p - /p
ul
li
..
li
/ul
p - /p
/div

but it produced

p - /p
/ul
/div

at the end, thus the list was not formally closed inside the div due to an illegal p.

Error was detected by the revision tool when i tried to upload the epub to Draft2Digital. I could edit the file myself in calibre, now it was accepted.

Attach a DOCX file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete

Hi, attached DOCX and resulting epub including the conflicting table.

  * The div declaration line (#11) does not open the UL tag before the
first list item LI.
  * Line #22 adds a Paragraph inside the list structure
  * Line #23 declares the List start (after the whole list...)
  * Line #24 closes the List

Cheers,

Alberto

El 15-05-2018 22:08, Kovid Goyal escribió:

> Attach a DOCX file demonstrating/reproducing the problem to this bug
> report. You can do that by clicking the "Add attachment or patch" link
> at the bottom of the bug's page. If the file you are attaching is
> copyrighted, mark the bug as private. You can do this by clicking the
> tiny yellow icon next to "This report contains Public information" in
> the top right area of the bug's page.
>
> status incomplete
>
> ** Changed in: calibre
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1771279
>
> Title:
> wrong tags order in list from DOCX
>
> Status in calibre:
> Incomplete
>
> Bug description:
> Calibre is 3.23.0 for Mac, Word is 2011 (also Mac). Original DOCX also
> edited in a Windows 7 machine, with Word 2016 (but last edition with
> 2011 for Mac).
>
> Upon exporting a list, the HMTL tags have an invalid order. Should be
>
> div
> p - /p
> ul
> li
> ..
> li
> /ul
> p - /p
> /div
>
> but it produced
>
> p - /p
> /ul
> /div
>
> at the end, thus the list was not formally closed inside the div due
> to an illegal p.
>
> Error was detected by the revision tool when i tried to upload the
> epub to Draft2Digital. I could edit the file myself in calibre, now it
> was accepted.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1771279/+subscriptions

Alberto Garcia (albertog72) wrote :

Hi, attached DOCX and resulting epub including the conflicting table.

The div declaration line (#11) does not open the UL tag before the first list item LI.
Line #22 adds a Paragraph inside the list structure
Line #23 declares the List start (after the whole list...)
Line #24 closes the List

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers