Edit Metadata glitch has column "Read Status" not showing properly

Bug #1766762 reported by Robin on 2018-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

After resetting the order of columns in the edit metadata my "read status" column is taking up two rows for the label to the left of the fixed response column, when all the other columns have their labels on one row. This leaves my edit metadata with a partially missing label.

Attached screenshot highlighting the column in the bulk metadata view, I also have the individual book view but I can seem to only attach one file.

Robin (robin-ellwood) wrote :

Changing the component for this bug.

 assignee cbhaley
 status triaged

Kovid Goyal (kovid) wrote :

@chaley: Most probably can be fixed by disabling wrapping on the QLabel
used for the control labels.

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) wrote :

@kovid: I am uncomfortable with that change for 2 reasons:

1) The change will break edit metadata for everyone who likes word wrap. It also can make it impossible for the edit metadata window to fit on the screen if the label text is very long.

2) I can't make it fail on windows. In every case I have tried the cell expanded vertically so that the label showed completely after word wrap. I wonder if this is an artifact of Qt on the OP's OS? Or perhaps the font metrics are incorrect?

@OP: What OS and calibre version are you running? Have you changed the interface font? If so, to what?

Kovid Goyal (kovid) wrote :

I suspect that it happens if there is layout pressure, i.e.e the dialog
is not tall enough to fit all the controls. Although I have to say, I
cannot make it happen either. And given that the dialog has scrollbars,
I dont know why there should be layout pressure at all.

Charles Haley (cbhaley) on 2018-04-27
Changed in calibre:
status: Triaged → Incomplete

​Change the font size to 11 (that was the problem) I reset it to 9 and it
went back to normal​

On Wed, Apr 25, 2018 at 1:26 AM, Kovid Goyal <email address hidden>
wrote:

> I suspect that it happens if there is layout pressure, i.e.e the dialog
> is not tall enough to fit all the controls. Although I have to say, I
> cannot make it happen either. And given that the dialog has scrollbars,
> I dont know why there should be layout pressure at all.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1766762
>
> Title:
> Edit Metadata glitch has column "Read Status" not showing properly
>
> Status in calibre:
> Triaged
>
> Bug description:
> After resetting the order of columns in the edit metadata my "read
> status" column is taking up two rows for the label to the left of the
> fixed response column, when all the other columns have their labels on
> one row. This leaves my edit metadata with a partially missing label.
>
> Attached screenshot highlighting the column in the bulk metadata
> view, I also have the individual book view but I can seem to only
> attach one file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>

Robin (robin-ellwood) wrote :

see attached metadata and json for recreation

On Fri, May 4, 2018 at 1:39 AM, robin ellwood <email address hidden>
wrote:

> ​Change the font size to 11 (that was the problem) I reset it to 9 and it
> went back to normal​
>
> On Wed, Apr 25, 2018 at 1:26 AM, Kovid Goyal <email address hidden>
> wrote:
>
>> I suspect that it happens if there is layout pressure, i.e.e the dialog
>> is not tall enough to fit all the controls. Although I have to say, I
>> cannot make it happen either. And given that the dialog has scrollbars,
>> I dont know why there should be layout pressure at all.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1766762
>>
>> Title:
>> Edit Metadata glitch has column "Read Status" not showing properly
>>
>> Status in calibre:
>> Triaged
>>
>> Bug description:
>> After resetting the order of columns in the edit metadata my "read
>> status" column is taking up two rows for the label to the left of the
>> fixed response column, when all the other columns have their labels on
>> one row. This leaves my edit metadata with a partially missing label.
>>
>> Attached screenshot highlighting the column in the bulk metadata
>> view, I also have the individual book view but I can seem to only
>> attach one file.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>>
>
>

Charles Haley (cbhaley) wrote :

Still can't reproduce it with the information given, trying 3 different font sizes. See the attached screen capture.

Could you give me:
- the text of the column order tweak?
- the actual font you are using?
- the OS and calibre version you are ruinning?

For the last one, the OS etc, best would be to post the beginning of a calibre debug log. That will also show if there is some DPI scaling going on. I don't have any idea why that might affect something, but it would be good to know.

Hi Charles,
Using os Windows 7, Calibre 3.24.2 copied from tweaks folder:

#: Order of custom column(s) in edit metadata

metadata_edit_custo000m_column_order = ['#rl1974', '#rl1221', '#sito',
'#merged_sito_in_the_cloud', '#readstatus', '#booksource', '#dateadded',
'#kindle', '#grdateadded', '#exclusiveshelf', '#book_style', '#genre',
'#dateread', '#grdateread', '#latest_read_date', '#rc', '#calibrelibrary',
'#details', '#currentbookshelves', '#all_book_sources', '#libdup', '#hide',
'#kobo', '#cleaned', '#bookshelves', '#all_the_read_dates',]

Was able to recreate the "read status" compression problem and I have
included a screenshot of the look and feel font settings at 12 (although
the problem was resolved at 10). Screenshots of the various edit metadata
gui (compact, default, all on one tab) these were shown while the font was
at 12. Also sent in a resolved screenshot at font 10

Finally, I added a bug log from when the font sizes was 12, but didn't add
the one that was created when the problem was resolved. Hopefully this
will give you all the info you need.

On Fri, May 4, 2018 at 2:22 AM, Charles Haley <email address hidden>
wrote:

> Still can't reproduce it with the information given, trying 3 different
> font sizes. See the attached screen capture.
>
> Could you give me:
> - the text of the column order tweak?
> - the actual font you are using?
> - the OS and calibre version you are ruinning?
>
> For the last one, the OS etc, best would be to post the beginning of a
> calibre debug log. That will also show if there is some DPI scaling
> going on. I don't have any idea why that might affect something, but it
> would be good to know.
>
> ** Attachment added: "Clipboard01.jpg"
> https://bugs.launchpad.net/calibre/+bug/1766762/+
> attachment/5133646/+files/Clipboard01.jpg
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1766762
>
> Title:
> Edit Metadata glitch has column "Read Status" not showing properly
>
> Status in calibre:
> Incomplete
>
> Bug description:
> After resetting the order of columns in the edit metadata my "read
> status" column is taking up two rows for the label to the left of the
> fixed response column, when all the other columns have their labels on
> one row. This leaves my edit metadata with a partially missing label.
>
> Attached screenshot highlighting the column in the bulk metadata
> view, I also have the individual book view but I can seem to only
> attach one file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>

Robin (robin-ellwood) wrote :

Sorry, Im using Calibre 3.22.1

On Tue, May 29, 2018 at 4:58 PM, robin ellwood <email address hidden>
wrote:

> Hi Charles,
> Using os Windows 7, Calibre 3.24.2 copied from tweaks folder:
>
>
> #: Order of custom column(s) in edit metadata
>
> metadata_edit_custo000m_column_order = ['#rl1974', '#rl1221', '#sito',
> '#merged_sito_in_the_cloud', '#readstatus', '#booksource', '#dateadded',
> '#kindle', '#grdateadded', '#exclusiveshelf', '#book_style', '#genre',
> '#dateread', '#grdateread', '#latest_read_date', '#rc', '#calibrelibrary',
> '#details', '#currentbookshelves', '#all_book_sources', '#libdup', '#hide',
> '#kobo', '#cleaned', '#bookshelves', '#all_the_read_dates',]
>
> Was able to recreate the "read status" compression problem and I have
> included a screenshot of the look and feel font settings at 12 (although
> the problem was resolved at 10). Screenshots of the various edit metadata
> gui (compact, default, all on one tab) these were shown while the font was
> at 12. Also sent in a resolved screenshot at font 10
>
> Finally, I added a bug log from when the font sizes was 12, but didn't add
> the one that was created when the problem was resolved. Hopefully this
> will give you all the info you need.
>
>
>
> On Fri, May 4, 2018 at 2:22 AM, Charles Haley <email address hidden>
> wrote:
>
>> Still can't reproduce it with the information given, trying 3 different
>> font sizes. See the attached screen capture.
>>
>> Could you give me:
>> - the text of the column order tweak?
>> - the actual font you are using?
>> - the OS and calibre version you are ruinning?
>>
>> For the last one, the OS etc, best would be to post the beginning of a
>> calibre debug log. That will also show if there is some DPI scaling
>> going on. I don't have any idea why that might affect something, but it
>> would be good to know.
>>
>> ** Attachment added: "Clipboard01.jpg"
>> https://bugs.launchpad.net/calibre/+bug/1766762/+attachment
>> /5133646/+files/Clipboard01.jpg
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1766762
>>
>> Title:
>> Edit Metadata glitch has column "Read Status" not showing properly
>>
>> Status in calibre:
>> Incomplete
>>
>> Bug description:
>> After resetting the order of columns in the edit metadata my "read
>> status" column is taking up two rows for the label to the left of the
>> fixed response column, when all the other columns have their labels on
>> one row. This leaves my edit metadata with a partially missing label.
>>
>> Attached screenshot highlighting the column in the bulk metadata
>> view, I also have the individual book view but I can seem to only
>> attach one file.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>>
>
>

Charles Haley (cbhaley) wrote :

I was able to repeat the problem and have submitted what is best called a workaround because the problem is almost certainly in QT itself.

Changed in calibre:
status: Incomplete → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released

What is "QT"?

On Fri, Jun 1, 2018 at 4:32 AM, Charles Haley <email address hidden>
wrote:

> I was able to repeat the problem and have submitted what is best called
> a workaround because the problem is almost certainly in QT itself.
>
> ** Changed in: calibre
> Status: Incomplete => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1766762
>
> Title:
> Edit Metadata glitch has column "Read Status" not showing properly
>
> Status in calibre:
> Fix Committed
>
> Bug description:
> After resetting the order of columns in the edit metadata my "read
> status" column is taking up two rows for the label to the left of the
> fixed response column, when all the other columns have their labels on
> one row. This leaves my edit metadata with a partially missing label.
>
> Attached screenshot highlighting the column in the bulk metadata
> view, I also have the individual book view but I can seem to only
> attach one file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>

Charles Haley (cbhaley) wrote :

"What is "QT"?"

The graphical interface toolkit (GUI) that calibre uses. If QT is broken then almost certainly calibre is equally broken. It is similar to when an Android app doesn't work because of a bug in Android itself.

Robin (robin-ellwood) wrote :

So I guess I am the first to come across this glitch.

On Fri, Jun 1, 2018 at 1:25 PM Charles Haley <email address hidden>
wrote:

> "What is "QT"?"
>
> The graphical interface toolkit (GUI) that calibre uses. If QT is broken
> then almost certainly calibre is equally broken. It is similar to when
> an Android app doesn't work because of a bug in Android itself.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1766762
>
> Title:
> Edit Metadata glitch has column "Read Status" not showing properly
>
> Status in calibre:
> Fix Released
>
> Bug description:
> After resetting the order of columns in the edit metadata my "read
> status" column is taking up two rows for the label to the left of the
> fixed response column, when all the other columns have their labels on
> one row. This leaves my edit metadata with a partially missing label.
>
> Attached screenshot highlighting the column in the bulk metadata
> view, I also have the individual book view but I can seem to only
> attach one file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1766762/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers