SEARCH field in Find & Replace does not allow all caps

Bug #1752447 reported by Robert Baust on 2018-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Maybe this is normal behavior, I'm new to regex. Win7-64, calibre 3.18.0

When creating Search & Replace expressions in the Format Converter dialog, typing "CHAPTER" in the Search field is automatically changed to "Chapter" when I move to the Replacement field. My intention is to replace the all caps "CHAPTER' with "Chapter", but it won't let me type all caps in the Search field. Well, it will let me type it, but I can't move away from the filed without it changing it. Since Search & Replace is supposed to be case-sensitive I would have thought it was legal to use all caps?

I did eventually figure a work-around, to group the Search string like "(CHAPTER)" which retains the all caps and does the replacement as I expected.

I cannot replicate. I am able to type CHAPTER, Chapter and chapter in
the find field and have it stay around after exiting the field.

I am guessing your problem is caused by the recently used entries popup
of the find field, it probably has an etry for Chapter that is getting
selected. Dont press Tab to exit the field, since that selects entries
from the list, instead click outside it.

 status invalid

Changed in calibre:
status: New → Invalid
Robert Baust (rbaust) wrote :

It's true that "Chapter" is in the recently used list, but your suggestion to click outside the search field does not work for me. See attached video. Other than typing a bunch of bogus search words to get rid of the offending word, is there any other way to stop calibre from forcing me to use a word from the list?

Kovid Goyal (kovid) wrote :

Oh, you're talking about the conversion dialog, for some reason I
thought you were talking about the editor, I'll take a look at it, when
I have a moment.

Changed in calibre:
status: Invalid → New

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers