Suggestions to the Configure menu of the Tag browser

Bug #1733151 reported by Jonatan Nyberg on 2017-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When clicking the Configure button there would be a link that says Add User category or Configure User categories, this is what people are looking for when they are clicking on the Configure button. Please also remove the Saved searches from the Manage authors, tag, etc. because that is already easy to find when clicking on Saved search in the Search field and has nothing to do with the Tag browser.

There already is under Manage authors/tags/etc.

And Saved searches are not going to be removed from the Tag browser.

 status invalid

Changed in calibre:
status: New → Invalid
Jonatan Nyberg (jony0008) wrote :

Then please make it possible to show Saved searches in the Tag browser.

Jonatan Nyberg (jony0008) wrote :

I see that it already possible to show Saved searches in the tag browser.

Could there be a Add Saved search and Add User category in the right click menu of the Tag browser instead?

Kovid Goyal (kovid) wrote :

Why? There is a perfectly accessible UI for creting saved searches
already.

Jonatan Nyberg (jony0008) wrote :

Sure, there are other ways.

I created a new User category and then a category with Searches containing Saved searches appeared in the Tag browser, why did it appear when I created a new User category and not when I created the Saved search? How can I choose to add Saved searches to the Tag browser? Is this a bug?

Charles Haley (cbhaley) wrote :

@kovid: the problem of a first saved search not showing is caused by the dynamic categories having been removed from field_metadata. 'search' is removed if there aren't any. Unfortunately, the dynamic categories are not recomputed when a saved search is added.

The problem is easily recreated.
1) delete all saved searches (or create a new library)
2) restart calibre
3) add a saved search using the button on the search line
4) you will see that the saved search category is not shown.
5) restart calibre. The category is now there.

I tried adding:
        self.current_db.new_api.initialize_dynamic()
after line 588 in gui2.search_box.py. This fixed the problem. I am telling you this way instead of submitting a patch because it isn't obvious to me that this is the right way to do the job. I am worried about side effects at the db level. You know much better than I do how that stuff works.

Kovid Goyal (kovid) wrote :

Creating a saved search makes the Searches category show up in the tag
browser automatically, unless you have hidden that category.

Kovid Goyal (kovid) wrote :

Ah, OK, I'll take a look at that, when I have a moment.

Changed in calibre:
status: Invalid → New

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers