Comment 3 for bug 1715781

I tried two books before giving up. It was the first time I'd used the server that way. It's not essential for my use of calibre, just thought you'd want to know.

I got the same error when using the mobile version of Chrome (so no extensions) on my Samsung phone, so it might simply be a Chrome issue. When using the Samsung browser I got cached data showing up (i.e. From the previous book).

I don't use Firefox so couldn't check that.


Sent from Outlook

From: <email address hidden> <email address hidden> on behalf of Kovid Goyal <email address hidden>
Sent: Thursday, September 7, 2017 7:06:08 PM
To: <email address hidden>
Subject: [Bug 1715781] Re: calibre bug 1715781

Oh and is this error specific to a particular book or all books?

You received this bug notification because you are subscribed to the bug

  Unable to read epubs in browser; fails when paging down

Status in calibre:

Bug description:
  When attempting to read an epub in the browser from the Calibre
  server, the first page will display but attempting to page down
  prompts an error. I am using Chrome to access the server.

  The error presented is:

  Could not open [book title]. Uncaught SyntaxError: Identifier 'kMaxFont' has already been declared
  Error at 7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
  Traceback (most recent call last):
      at blob:null/7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
  SyntaxError: Identifier 'kMaxFont' has already been declared

  Calibre v 3.7, x64 on Windows

To manage notifications about this bug go to: