Unable to read epubs in browser; fails when paging down

Bug #1715781 reported by Ian ten Cate on 2017-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When attempting to read an epub in the browser from the Calibre server, the first page will display but attempting to page down prompts an error. I am using Chrome to access the server.

The error presented is:

Could not open [book title]. Uncaught SyntaxError: Identifier 'kMaxFont' has already been declared
Error at 7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
Traceback (most recent call last):
    at blob:null/7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
SyntaxError: Identifier 'kMaxFont' has already been declared

Calibre v 3.7, x64 on Windows

There is no kMaxFont anywhere in calibre. Make sure you are using an
up-to-date version of Chrome and if you are, then try running with a
clean profile or at least all extensions disabled.

 status invalid

Kovid Goyal (kovid) wrote :

Oh and is this error specific to a particular book or all books?

Changed in calibre:
status: New → Invalid

I tried two books before giving up. It was the first time I'd used the server that way. It's not essential for my use of calibre, just thought you'd want to know.

I got the same error when using the mobile version of Chrome (so no extensions) on my Samsung phone, so it might simply be a Chrome issue. When using the Samsung browser I got cached data showing up (i.e. From the previous book).

I don't use Firefox so couldn't check that.

Ian

Sent from Outlook

________________________________
From: <email address hidden> <email address hidden> on behalf of Kovid Goyal <email address hidden>
Sent: Thursday, September 7, 2017 7:06:08 PM
To: <email address hidden>
Subject: [Bug 1715781] Re: calibre bug 1715781

Oh and is this error specific to a particular book or all books?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1715781

Title:
  Unable to read epubs in browser; fails when paging down

Status in calibre:
  Invalid

Bug description:
  When attempting to read an epub in the browser from the Calibre
  server, the first page will display but attempting to page down
  prompts an error. I am using Chrome to access the server.

  The error presented is:

  Could not open [book title]. Uncaught SyntaxError: Identifier 'kMaxFont' has already been declared
  Error at 7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
  Traceback (most recent call last):
      at blob:null/7127eb36-d394-48bb-bc90-a2e5a6608bee:1:1
  SyntaxError: Identifier 'kMaxFont' has already been declared

  Calibre v 3.7, x64 on Windows

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1715781/+subscriptions

The reader most definitely works with (up-to-date) versions of Chrome.
Attach one of these EPUB files and I wills ee if I can reproduce the
error.

Ian ten Cate (itencate-hotmail) wrote :

Looks like it might have something to do with the actual epub - some will load just fine.

Ian ten Cate (itencate-hotmail) wrote :

BTW, please remove the file after use for diagnosing the issue. Thanks.

Kovid Goyal (kovid) on 2017-09-10
information type: Public → Private

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

information type: Private → Public
Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers