Calibre 3.6 crashes while fetching news

Bug #1711224 reported by darkom on 2017-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

OS: Ubuntu 16.04 64bit

I just installed Calibre 3.6 and tried fetching Harper's magazine. At the very end of the process it crashes with long error dump (see attached file).

Any suggestions?

darkom (darko-miletic) wrote :

That recipe downloads fine to MOBI for me on linux. Is it only Harpers, or all
recipes?

Kovid Goyal (kovid) wrote :

However, I just realized that this is a subscription news source and I
dont have an account, so it not crashing for me is not useful. You can
run it from he command line using ebook-convert with the --debug-pipeline
option and zip up the input directory from the debug folder, I will try
to replicate it with that.

ebook-convert file.recipe output.mobi --debug-pipeline p

Then send me the p/input directory

darkom (darko-miletic) wrote :

Here is the complete dump

darkom (darko-miletic) wrote :

If you still need my credentials let me know and I'll pass it over.

Kovid Goyal (kovid) wrote :

This looks like it is caused by a bug in the html5-parse library that
calibre recently switched to. I'll look into it when I have a moment, in
the meantime, you can probably fix it by simple removing

.articlePost p:first-letter{display: inline; font-size: xx-large; font-weight: bold}

from extra_css in the recipe.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers