Content server: No way to return after footnote

Bug #1700004 reported by Omar Ashhab on 2017-06-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

In the new web reader, clicking on a footnote number in the text will take me to the footnote (usually at the end of the book), but there is no way to get back to the main text. When I right-click to reveal the menu and click "Back" it closes the book and returns to the list of books, instead of going back to the main text.

Calibre 3.0.0
Linux openSuse

Thank you for fixing this.

I cannot replicate this, clicking any link in a book, including a
footnote link, takes me to the page of the link and clicking back,
either in the viewer controls or the browser back button, takes me back
to the original page (or in a few rare cases the page before it).

The only caveat is that if you click back immediately after clicking the
link it wont work (you have to wait approx. a second).

Tested in Chrome and Firefox.

 status invalid

Changed in calibre:
status: New → Invalid
Tracy Poff (tracy-poff) wrote :

I am also experiencing this issue. I'm using Calibre 3.2.1 and Chrome 58 on Windows 10. When clicking a footnote link, I see the URL in the address bar change to reflect the new position, but both the back button inside the content and the browser's back button take me back to the book details page, and the '<--' button at the left side of the page simply takes me to the previous footnote.

I speculate that the ebook viewer is doing history.replaceState rather than history.pushState.

Kovid Goyal (kovid) wrote :

No, it does replaceState of scroll and pushState on navigate (at least
that is what is is supposed to do). Hard for me to debug since I cannot
reproduce. Attach a book for which you see it happening (along with a
pointer to where in the book the misbehaving footnote is).

Tracy Poff (tracy-poff) wrote :

The attached epub exhibits this behavior reliably for me.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers