some covers don't show up in reading apps since 3.0 update

Bug #1699932 reported by Angela Resler on 2017-06-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I’m not sure if this is considered a bug or not so if I am posting this in the wrong place I would really appreciate it if you are able to point me in the right direction to fix this.

This began on June 16 after I downloaded the 3.0 update. My issue involves a combination of Calibre, FanFicFare, the Marvin reading app I use on my iPad, and possibly the Generate Cover Plugin. I will explain what I have always been able to do prior to the 3.0 update and how that has changed since the update. All apps mentioned in this post are apps I used on my iPad (2017 version) and have the current update installed. I am running this on Windows and downloaded the 3.0 64-bit update.

THEN: How things worked BEFORE the update:

Step 1: Using the FanFicFare Plugin, I download/add fanfiction stories (fics) from www.archiveofourown.org to Calibre in epub form.

Step 2: Some fics have images in them and FFF will use the first image found as the cover for the fic, however most fics do not have images. For those fics without covers I add covers using the Generate Cover Plugin.

Step 3: Add fics to Marvin 3 &/or Marvin SxS reading apps on my iPad. Marvin automatically searches for the Calibre content server when I tap the option that says “OPDS auto or calibre server.” It searches and I will get the message “1 found,” which I tap. I then get a screen that says “Connect To” and I tap the address. This is the method I use to add Calibre items to my Marvin apps. It is fast, easy, and I can add multiple books at one time.

NOW: How things work after updating to 3.0 on June 16:

I do everything just like before: I use FanFicFare to get fics from AO3. If the fics do not have covers from AO3 I use the Generate Cover Plugin. The problem then comes when I add fics to Marvin from Calibre using the content server. The content server will still show a list with all my books in my Calibre library and just like before, that list will show the book’s cover, author, and title. I am still able to download them to the Marvin app, complete with all the metadata such as tags, publication dates, etc, however since the 3.0 update ***the covers I made using the Generate Cover plugin no longer show up in my Marvin library.*** If a fic “came with” a cover when FanFicFare added it to Calibre that cover will still show in my Marvin library. Covers will also show up in Marvin if I add a published book (non-fanfiction) from Calibre that I purchased from a retailer. It seems like the only covers that do not show up in Marvin are the ones I created with the Generate Covers plugin.

Here are two of the most notable things I discovered in the last few days:
ALL covers (original covers and covers made with the Generate Cover Plugin) WILL show up in Marvin if I first connect to Dropbox in Calibre, add fics to Dropbox, and then add them to Marvin using Marvin’s “Get Books-Dropbox” option instead of adding them via Marvin’s “Get Books-OPDS auto or calibre server” option. This is not at all convenient.
I tested this in another epub reading app (Nook) and found I can add books to the Nook reading app by first going into the Dropbox app and then exporting/opening in the Nook app. But the covers DID NOT show up in the Nook app when doing it this way. (I don’t believe the Nook app will connect to the Calibre content server like the Marvin app is able to do. Adding with Dropbox was the only way I could think of to add Calibre books to the Nook app.)
Thoroughly frustrated, I uninstalled the 3.0 update and reinstalled the previous update. Everything worked fine, just as it always did. I would leave it that way but that just leads me to another problem: when I leave the old version installed there is a message in the lower right corner alerting me: “Update Available 3.0” For some reason, every time that message shows up it messes with my laptop’s split-screen function. I almost always have Calibre open in one half of my screen, with Chrome open in the other half. That “update available” alert always causes Calibre to take up 75% of the screen and I am unable to get it to resize like normal. This makes anything I have open in the other 25% very hard to view. But as soon as I update Calibre and the message disappears, my split screen works as it should. Weird and annoying and a problem for a different forum, but inconvenient enough to make me want to get 3.0 to work the way IT should.
I finally reinstalled 3.0, started over, and I still have the issues.

For now, my “solution” to getting covers to show up (with the 3.0 update) has been to download fics with FanFicFare and use Generate Covers just as I have always done, but now I have to add another step. I have to right click on the fic, select Convert> Convert Individually> OK. (I think this also works for bulk conversions but I have only tried it once). I don’t actually make any changes when I open the Convert box, I just click OK at the bottom. The covers now appear in my Marvin library when I add fics with the Calibre server. The covers will also show up in the Nook app if I do the conversion before adding the fic to Dropbox and then exporting/opening with Nook app. But I don’t actually use the Nook app, I just used it to see if my issues were exclusively with Marvin. It DOES NOT work if I Convert the books first and then go in and Generate Covers.

So is this considered a “bug” and am I posting this in the right place?

The only changes with regard to covers in calibre 3.0 is that the HTTP
response now uses the ETag and the size of the covers is not restricted any
more. I'm guessing that Marvin is only able to load covers upto a certain
size via OPDS. However, as I have no way to debug Marvin, it is hard for me to
say. Your best bet is to report the issue to the Marvin developer, and tell
him to contact me either here, or in the calibre forums and I will be
happy to offer any assistance needed to resolve the issue.

As for your 75% window width issue, it is likely because the update
message makes the minimum width of the status bar too large to fit in
50% of your screen. Probably reducing the calibre interface font size
will fix that.

 status invalid

Changed in calibre:
status: New → Invalid
Angela Resler (addictedreader) wrote :

Thank you very much for your help. I will try what you have mentioned.

Rui Hanazawa (rui-hanazawa) wrote :

I'm experiencing the same issue on Calibre 3.30. I'm just accessing the calibre remotely so I can't update at the moment but I checked the changelog for 3.31 and I don't believe there were changes that might have fixed this going from 3.30 to 3.31.

I don't believe the issue is with Marvin. Images display just fine on the OPDS feed and webpage. It's when the books are downloaded that the covers don't show up in the Marvin library.

I tried both automatic OPDS (via Marvin) and then Safari to download the ebook and the file size seemed too small (~100KB) to have a cover (~300KB jpg). The downloaded epub contains updated metadata but I don't believe it has the cover embedded.

I thought the content server just used the same setting as Save to Disk/Send to Device and I believe those embed generated covers. I wonder, is this perhaps intended behavior for the content server? If yes, is there a setting to force the cover embed for content server downloads? Thank you very much for your time!

Kovid Goyal (kovid) wrote :

cover embedding when updating metadata only works if the EPUB file has a
properly designated cover in the first place. Do an EPUB to EPUB
conversion to guarantee a cover update for all EPUBs. Otherwise it ill
not work if the original EPUB does not have a properly designated cover.

Rui Hanazawa (rui-hanazawa) wrote :

Okay, thanks!

I guess the content server doesn't function exactly as "Save to disk" so I got a bit confused as I seem to remember reading somewhere that they were supposed to work the same.

On the exact same book (original epub does not contain properly designated cover), epub exported via "Save to disk" has updated metadata and embedded cover. Meanwhile, epub exported/downloaded via content server has updated metadata but no cover.

Kovid Goyal (kovid) wrote :

That should not be the case, if it is for some EPUB please attach it to
this bug report and I will take a look.

Rui Hanazawa (rui-hanazawa) wrote :

Instead of just the epub, I'm attaching a small subset of the library as well as my settings from Calibre Portable for easier replication.

user/pw for the sever is reader/reader

I updated to Calibre Portable 3.31 and behavior is still the same as 3.30 (Save to disk embeds cover, Content Server does not). I normally run Polish books to embed metadata and cover. I didn't have time to run Polish this time so it's the first time I've encountered this issue. I have no idea if the bug is present on older versions or not.

Please let me know if you require additional info.

Thanks!

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
Rui Hanazawa (rui-hanazawa) wrote :

Awesome. Thank you very much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers