get books search will not find mature content in smashwords

Bug #1698943 reported by MichaelJ on 2017-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

i was testing the get books search function using just the english language serving stores like amazon, google, kobo, smashwords and others.

it took a while of experimentation to figure out that just entering unique phrases in the title field would not return relevant results, had to go use the non-obvious magnifying glass for advanced search options which basically just ends up being Keyword field entry style of

title:"whatever should be in the title"

testing with a mature theme book title returns expected book result from main sites, but not Smashwords.

i tried looking through smashwords site and general web to find a way to include mature content while making the search request, but nothing after more than an hour of trying, and even an attempt at adding on to search string with keyword guesses.

access seems to be set via cookie on smashwords site to toggle between 3 states of "filtered for all ages" > "mature" > "mature + erotica", and i did not see anything obvious about how calibre handles cookies, but maybe all that can be done is adding a note to the plugin that results will only include "all ages" content.

reproduce by searching for any mature theme title currently listed on smashwords.

Kovid Goyal (kovid) wrote :

Adding cookies to calibre requests is quite easy as it uses mechanize. If you tell me the details of the cookie that needs to be added, I can add it. You can find out by examining the cookies in your browser.

Changed in calibre:
status: New → Incomplete

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
MichaelJ (jmichael2497) wrote :

hi, sorry i did not think to include cookie values in the initial report, i will keep that in mind for the future.

glad to try and help with at least detailed bug reproduction reports.

thanks for the quick search and fix, cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers