Keyboard shortucts not working in Calibre 3.0

Bug #1698545 reported by Daniel Hauenstein on 2017-06-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Since the update to Calibre 3.0 some of my keyboard shortcuts are working anymore.
It seems that this is only the case for shortcuts without any special key (such as "S" for exporting ebooks). I have have not changed the shortcut settings, most of them are set to default.

Bug is easily reproducible:
1) Open Calibre
2) Select any book
3) Press "S" for exporting - nothing happens, expected: Book gets exported

Please note that this seems to be the case only for _some_ shortcuts, for instance "V" (preview) still works.

Calibre Version: 3.0
Operating System: macOS Sierra 10.12.5

Both S and V continue to work on my OS X machine. Check that the
shortcut is still assigned in Preferences->Keyboard. Does saving books
to disk work if you click the actual button?

Daniel Hauenstein (dhauenstein) wrote :

Yes, the shortcuts are still assigned. Functionality is not flawed when I use the buttons, everything works here as expected. It's just annoying, because I use a lot of shortcuts in my workflow.
I'd like to point out this happens after upgrading to 3.0. I also switched to a different theme, not sure if this is of relevance.

Kovid Goyal (kovid) wrote :

What theme? You mean system style in Preferences->Look & Feel?

Daniel Hauenstein (dhauenstein) wrote :

Sorry, yes that's what I mean, more specifically the icon set, not the UI style.
Since this is only the Icon set (it's set to monstre now) I'd assume this would not have any effect on the shortcuts.

Daniel Hauenstein (dhauenstein) wrote :

FYI, just switched to the "Classic" icon theme and restarted, shortcuts are still not working.
As I said, this happened right after upgrading from 2.x to 3.0 - so I'd assume this might be connected to the upgrade.

Daniel Hauenstein (dhauenstein) wrote :

So, I started calibre-debug -g (sorry, should have done that before), and here's what the log says when I press "s":
QAction::eventFilter: Ambiguous shortcut overload: S

The GUI states that there is no collision with the "s" shortcut (and it definitely was not with the 2.x versions)

Maybe that helps?

Daniel Hauenstein (dhauenstein) wrote :

Here's a screenshot of the GUI shortcut config

Kovid Goyal (kovid) wrote :

Are you using the English version of calibre or a localized version?
There is definitely no shortcut conflict in the English version. The
other source of conflicts is third party plugins, which you can
eliminate by running calibre like this

calibre --ignore-plugins

Elijah Bailey (iasimov) wrote :

Hello, same issue with the M shortcut in order to merge books and other 1 letter shortcuts. I've got the issue just after the update on MacOs with Calibre 3.0.

Hi,
I started with "--ignore-plugins", same problem.
As mentioned above, I have the same issue with M shortcuts as well.

Also, I usually use the german i18n version, but have the same issues with the english version (after switching to english and restarting the application)

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released

Awesome, that was quick. Thanks a lot!

Elijah Bailey (iasimov) wrote :

Thanks Kovid ;-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers