Saving books to single directory has truncate issue

Bug #1665964 reported by Makurosu on 2017-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

This is a minor issue. When selecting "Save only EPUB format to disk in a single directory" where the following save template is specified in Preferences:

{author_sort}/{title}/{title} - {authors}

Calibre still subtracts the string length of the folder /{author_sort}/{title} from the string length of the save file name and truncates it if it exceeds the max length. It shouldn't count the folder length if all the EPUB files are being saved to a single directory.

For example, if the book "Mark Twain - Huckleberry Finn" is saved along with other books to a single directory, I presume Calibre will compare the length of the string "/Twain, Mark/Huckleberry Finn/Huckleberry Finn - Mark Twain" and truncate it if it exceeds the max file length. It should only compare "Huckleberry Finn - Mark Twain" in this case, because it's being saved to a single directory.

I work around this issue by deleting the folders from the save template.

I think this might be the cause of other bugs I've seen where users report filenames being truncated at random.

Best regards!

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers