calibre injects artifacts in PDF on p.blockcenter

Bug #1665835 reported by Mark Robbins on 2017-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Windows 10
Calibre 2.70

WHEN converting a .epub to PDF using Calibre it installs artifacts EVERY TIME it hits this:

p.blockcenter {
font-family: courier, monospace;
text-align:center;
margin:0.5em 0em 0em 1em;
}

<p class="blockcenter">I think it's time that we all wear white hats.</p>

Which, eg. leaves (roughly) " I
                            w"

 PDF editors like 'Adobe Acrobat PRO DC' can't seem to work with them at all: can't delete, key over, move

Sometimes, if the 'blockcenter' is rather long, it just inserts multiple lines with a single ghosty character

Whatever they are, I can't even copy them to show you.

Here's a try:

believe that freedom speaks to all people.
<<missing:I believe we should all wear white hats.>>
I found it disturbing

Notice that the part I mentioned above is not visible here either. Weird.

Attach an EPUB file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny lock icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
Mark Robbins (senatormark4) wrote :

This is the epub file that it is choking on with quite a few p.blockcenter formats

Kovid Goyal (kovid) wrote :

The problem is caused by the Courier font, which has issues with Qt WebKit, the library calibre uses for HTML rendering. Use the calibre editor manage fonts tool to remove courier and re-convert, you will be fine.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers