calibre does not build reproducibly

Bug #1654211 reported by Bernhard M. Wiedemann on 2017-01-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When building calibre (e.g. on openSUSE),
resulting packages always slightly differ,
because available_input_formats returns results in random order

See https://reproducible-builds.org/ for why this is bad.

Please apply the attached 1-line patch.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers