Search ignoring HTML markup in book editor ignores "Dot all"

Bug #1649383 reported by Raúl Núñez de Arenas Coronado on 2016-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre 2.74 64bit
Windows 10 Home 64 bit

When using Calibre's book editor, the "Dot all" setting doesn't work in "Search ignoring HTML markup", it performs searches as is the option was always checked.

I've used Find & Replace with a regex and it correctly matches differently if "Dot all" is in effect, not matching newlines with a dot unless the option is checked, but in Search ignoring... the exact same regex matches as if "Dot all" was actually checked, no matter if it is checked or not.

If needed I can provide a small epub with some example regexes to reproduce the problem.

As always, Kovid, thanks a lot for Calibre, and for fixing bugs SO FAST :)

Raúl

A sample would help

 status incomplete

Changed in calibre:
status: New → Incomplete

Kovid, the problem seems to be that in "Search ignoring HTML markup" the entire file contents are considered a single string, because "$" only matches at end of last paragraph in file.

Anyway, here you have an EPUB containing the testing text, the regexes and instructions to reproduce the problem.

If you need me to perform other test or whatever, I'm here.

Thanks again, Kovid :)

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments