bibtex labels

Bug #1646239 reported by Gigi on 2016-11-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hello
I created a bibliography with Calibre with an entry for a book whose author's name contains an accented letter

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
BIBLIOGRAPHY

\begin{thebibliography}{1}

\bibitem{JohnleCarré2231}
John le~Carré.
\newblock {\em Call for the Dead}.
\newblock Jan 1970.

\end{thebibliography}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

Using the following Latex file

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
LATEX FILE

\documentclass[11pt]{article}
\usepackage[utf8]{inputenc}
\begin{document}

\begin{thebibliography}{1}

\bibitem{JohnleCarré2231}
John le~Carré.
\newblock {\em Call for the Dead}.
\newblock Jan 1970.

\end{thebibliography}

\end{document}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

the compilation ended with an error message

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
LATEX ERROR MESSAGE
! Missing \endcsname inserted.
<to be read again>
\unhbox
l.2 ...p \spacefactor \accent@spacefactor 2231}{1}
The control sequence marked <to be read again> should
not appear between \csname and \endcsname.
)

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

to my understanding the presence of an accent "JohnleCarré2231" into the \bibitem{} generates an error message from latex that seems unavoidable
thanks
Pierluigi

Version 2.73
Ubuntu

If the version of latex you use cannot handle UTF-8 keys, tell calibre
to produce ascii encoded entries by changing the Bib file encoding
option to ascii/LaTeX in the BiBTeX options tab of the create catalog
dialog.

 status invalid

Changed in calibre:
status: New → Invalid
Gigi (pzezza) wrote :

Thanks for your answer but the problem is handling UTF-8 keys inside the quotation key \bibtem because it does not accept macro and with the utf8 encoding it becomes a LICR macro (LaTeX Internal Character Representation), and this causes the error
regards
Pierluigi

Kovid Goyal (kovid) wrote :

I'm confused, I though you said the problem was the presence of utf-8
characters, with the option I told you about there will be no utf-8
characters any more. If you are saying that it cannot handle latex
escapes either, then you can always remove the author from the key name
by changing the setting "expression to form the bibtex citation tag" to
just {id} instead of {authors}{id}

Kovid Goyal (kovid) wrote :

And I suppose I can also add some code to replace non-ascci characters
in citation keys with their ascii equivalents so that you can continue
to use keys that contain more than the {id}

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers