Cover Generator Format

Bug #1638759 reported by Robert Myres on 2016-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When generating a cover, the Series and Number are placed under the Title in Italics; except the characters after the first Roman Numeral are not in Italics. The entire line should be all Italics.

Calibre 2.71 (64bit)
Windows 7

None of the roman numerals are in italics because IMO Roman numerals in
italics look bad with many common fonts.

You can change that if you prefer to have them in italics by customizing
the cover generation process. Long click the generate cover button to
get the customization dialog and in the text section change the subtitle
template to include an <i> tag for the series number as well.

The changed template would look something like:

{series:'test($, strcat("<i>", $, " - ", raw_field("formatted_series_index")), "</i>")

 status invalid

Changed in calibre:
status: New → Invalid
Robert Myres (rcmyres) wrote :

I agree with you on that "Roman numerals in italics look bad." I did not understand, per your comment, that the cover generator is designed so that the Roman numerals style is to be "Regular."

Knowing this, I will restate the issue: "The first character of the Number Field in being italicized."

For example, the number 3 looks like this: /||

This is a minor issue but thought you should know.

Robert Myres (rcmyres) on 2016-11-03
Changed in calibre:
status: Invalid → In Progress
Kovid Goyal (kovid) wrote :

I cannot reproduce that, see attached.

Changed in calibre:
status: In Progress → Invalid
Robert Myres (rcmyres) wrote :

I performed a further test using another user account on the same machine and found the cause of the problem.

First Test
----------
Series: Barsoom
Number: 3
Result: Barsoom - III

Second Test
-----------
Series: Barsoom & Other
Number: 3
Result: Barsoom - /II

Conclusion:
The problem is caused by the ampersand (&) within the Series field.

Changed in calibre:
status: Invalid → In Progress

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers