Editor:Arrange Folders problem on Windows

Bug #1633875 reported by Jackie Stockdale on 2016-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre 2.70, Win10. Maybe this is a Windows-only problem.

It happens when using 'Tools-Arrange into Folders' when your Editor default folder map only differs from the existing folder layout because of case, e.g. trying to change a book whose HTML files are currently in a 'Text/' subdir and your default folder map specifies 'text/'.

I don't know how others use this Tool but I know I don't give the existing folder structure a second thought before using it. The main problems are:

1. calibre successfully changes the contents of all the internal files, links etc from 'Text/...' to 'text/...', and shows no errors if you run Check Book afterwards. The problem is only apparent after you save the file then re-open it in the Editor. Then it becomes clear that Windows has failed to change the physical subdir from 'Text/' to 'text/' and every HTML file is now in Miscellaneous.

2. calibre does not pre-warn that (as far as Windows is concerned) you are changing like-to-like.

In case you need one, I've attached a sample epub. Just run 'Arrange into Folders' with the Text map set to 'text/'. Save it and reopen.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers