Calibre doesn't allow non-ascii usernames

Bug #1619056 reported by Göran Uddeborg on 2016-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When I try to start calibre, I get a backtrace that ends with

  File "/usr/lib64/calibre/calibre/utils/ipc/__init__.py", line 43, in gui_socket_address
    ADDRESS = (u'\0%s-calibre-gui.socket' % user).encode('ascii')
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 2: ordinal not in range(128)

My login is "göran", so this isn't really surprising given the above code. I'm not sure why the address needs to be converted to ascii. But if it has to, perhaps the conversion could be made less strict, e.g.: encode('ascii','replace')

Non-ASCII login names are probably violating some standard somewhere, and a strict reasoning might claim this is not a bug. But does calibre really have to be that restrictive?

Environment:
Fedora Linux
calibre-2.65.1-1.fc25.x86_64

description: updated

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers