Data error when closing calibre

Bug #1610539 reported by ki4cxt on 2016-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Select one or more books.
Select 'save to disk'
Select 'save only epub format to disk'
Select the directory you want

calibre saves the files, but when you close the program, you get the following error:

Traceback (most recent call last):
  File "site-packages\calibre\gui2\library\models.py", line 1054, in setData
  File "site-packages\calibre\gui2\library\models.py", line 1128, in _set_data
  File "site-packages\calibre\db\legacy.py", line 431, in set
  File "site-packages\calibre\db\cache.py", line 57, in call_func_with_lock
  File "site-packages\calibre\db\cache.py", line 1058, in set_field
  File "site-packages\calibre\db\write.py", line 516, in set_books
  File "site-packages\calibre\db\write.py", line 191, in set_title
  File "site-packages\calibre\db\write.py", line 182, in one_one_in_books
  File "site-packages\calibre\db\backend.py", line 820, in executemany
  File "site-packages\calibre\db\backend.py", line 799, in conn
AttributeError: 'DB' object has no attribute '_conn'

Calibre ver 2.63 (same error in several older versions)
Os = Windows 10, 8.1, 8

Hope this helps in tracking down the bug.

I cannot reproduce using those steps. Looking at the traceback I'd guess
that what is happening is that you clicked on an already selected book
in the book list, which triggers the edit cell function and then you
clicked close with the cell edit still open.

I have added a check for this so that itaborts the edit silently during
shutdown.

 status invalid

Changed in calibre:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers