output catalog of the books problem

Bug #1602908 reported by toi ta on 2016-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

Hello,
Thank you for your wonderful-caliber software
My name is Tran. I come from Vietnam.
I need help using it.
In Calibre, I created the personalized columns.
After, I would like to create a catalog of the books
the output format is CSV, which i opened in Excel.
the problem is that out as custom columns is output odd characters of the form: [u'Th \ xf4ng t \ u01b0 ']
Which should normally be: Thông tư

Thank you for your help.
Attached is a picture of this problem.

toi ta (congtacbao) wrote :

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Kovid Goyal (kovid) wrote :

@charles: The relevant code is line 118 (and below) of csv_xml.py
What would be the correct way to format the field?

Charles Haley (cbhaley) wrote :

@kovid: as far as I can tell this is completely an excel problem. It appears that the default input coding is latin-1, at least on my old version of excel. One must do something special to make it import UTF-8

@toi ta: For instructions on how to import a UTF-8 CSV file into excel, see
https://www.itg.ias.edu/content/how-import-csv-file-uses-utf-8-character-encoding-0

Changed in calibre:
status: Triaged → Invalid
Kovid Goyal (kovid) wrote :

The CSV catalog starts with a UTF-8 BOM so it should import fine. Looking at the screenshot, the problem seems to be that the column #loaivanben is somehow being output as the result of repr() on a python list.

Charles Haley (cbhaley) wrote :

Well, it appears that excel can choose the wrong encoding, at least for me, but that is neither here nor there.

I pushed a fix for custom is_multiple columns.

Changed in calibre:
status: Invalid → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released

Hello,
I want to add that for custom type columns "Text, column shown in the tag
browser" it works.
but to type "comma separated text, like tags, shown in the tag browser", it
has problems as indicated

thank you!

On Thu, Jul 14, 2016 at 4:09 PM, Kovid Goyal <email address hidden>
wrote:

> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1602908
>
> Title:
> output catalog of the books problem
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Hello,
> Thank you for your wonderful-caliber software
> My name is Tran. I come from Vietnam.
> I need help using it.
> In Calibre, I created the personalized columns.
> After, I would like to create a catalog of the books
> the output format is CSV, which i opened in Excel.
> the problem is that out as custom columns is output odd characters of
> the form: [u'Th \ xf4ng t \ u01b0 ']
> Which should normally be: Thông tư
>
> Thank you for your help.
> Attached is a picture of this problem.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1602908/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments