Edit-book: After removing CSS file the program should also remove all references to that file from HTML files

Bug #1596048 reported by Robert Błaut on 2016-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Steps to reproduce bug:

1) Open to edit pub file with CSS file referenced to HTML files.
2) Remove that CSS file from EPUB file.

Expected result:
Edit-book should also remove all references from HTML files. Fox example:
<link href="../Styles/custom.css" rel="stylesheet" type="text/css" />

Current result:
References exist:

Warning [7 / 37]
OEBPS/Text/001.xhtml (line: 9 column: 0)
The resource pointed to by this link does not exist. You should either fix, or remove the link.

Robert Błaut (1-robert) on 2016-06-24
description: updated

It does not do that by design. Removing a resource could be the first
step in replacing it with something else, so removing all references to
it automatically will make it much harder to track down all locations
where something else should be done.

 status wontfix

Changed in calibre:
status: New → Won't Fix
Kovid Goyal (kovid) wrote :

What I could do is add an auto-fix option to Check Book for this type of
error, which auto-removes all links pointing to the missing resource.

Robert Błaut (1-robert) wrote :

The auto-fix option will be definitely great and for my needs completely sufficient :)

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers