Fullscreen toggle loses place in document

Bug #1595307 reported by mike on 2016-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre: 2.5.3
OS: Fedora 23

I'm trying to read a book actually sitting at my desk and a very annoying bug has popped up. I very much like the fullscreen option, but it seems when reading a .mobi, and .epub, (possibly all formats) the reader, when coming out of fullscreen, loses the position or page.

This is understandable to a degree, since the in-fullscreen area and the out of fullscreen area have different margins, and the out of fullscreen area has a variable margin. The problem is, though, that the bug seems to cause a 'ratcheting' effect, whereby the page position continually gets worse each time you do it.

I would expect that, when leaving fullscreen, the view should anchor on the very topmost paragraph position. That way at least if margins are a concern, you don't completely lose your place. I would also expect that, when going back into fullscreen, it is also anchored on the topmost (or closest to it) paragraph position in relation to the page that it will render.

I'm not exactly sure how to solve this problem but I hope you understand what I think is wrong.

I'm pretty sure you can replicate this by just bringing up any epub or mobi and enter/exit fullscreen.

The end result with this bug is that I as the user get really annoyed when I frequently enter/exit fullscreen mode, and I have to spend time finding my place over and over again.

It cannot be precise in paged modde, this is because in paged mode, when
the window size changes, the page size changes. Which means that the top
paragraph in one size is not longer the top parapgraph in another size.
Therefore anchoring on the top paragraph (which is what the viewe does)
does not mean that the top paragraph will actually remain at the top
through a transition.

If you want precise transitions, switch to flow mode (click the yellow
scroll icon at the top right corner).

 status invalid

Changed in calibre:
status: New → Invalid
mike (mike+ubuntu1) wrote :

Why not then just ensure that the top paragraph remains in view during either in or out transition? That would at least prevent the ratcheting effect..

I know it's tempting to just mark bugs and clear them out as soon as possible to avoid clutter, but please attempt to test the workflow of someone that wants to use this fullscreened frequently but also often needs to break away and unfullscreen the application. Perhaps there's some other way you can improve upon that workflow?

As far as flow mode, I prefer paged mode...

Please I urge you to just try what I am telling you and you'll see that something isn't right.

Kovid Goyal (kovid) wrote :

The top paragrpah does remain in view durung every individual
transition. The problem is that the top paragraph is different for each
successive transition. Read what I wrote again, and spend some time
thinking about it. And kindly dont make assumptions about why I close
bug reports.

mike (mike+ubuntu1) wrote :

So you're telling me the behavior displayed in the attached video is normal?

Notice how it "ratchets" instead of anchoring on a particular paragraph, except for when it reaches a chapter heading, then finally it does what I feel it should do all the time.

Kovid Goyal (kovid) wrote :

Sigh. Yes, it is normal. It is an unavoidable result of the way pages work.

Kovid Goyal (kovid) wrote :
Kovid Goyal (kovid) wrote :

And thinking about it, I suppose I can generalize the mechanism I
mentioned in the other bug report to work for full screen toggles as
well as footnote popups. So in the case where you switch to fullscreen
and nack without doing anything else in the middle the viewer will now
remember its page exactly.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released

Thanks!

On Thursday, June 23, 2016 7:01:36 AM EDT you wrote:
> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Invalid => Fix Released

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers