Edit ebook, merge selected text files fail.

Bug #1535427 reported by edward.81 on 2016-01-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

- Calibre 2.49
- Os: Archlinux

In edit ebook (epub) interface if i try to merge two text files the operation fail with the error "The master file must be one of the files being merged". To do it i select the .html file with the keyboard ctrl key hold down. Then from the menu i chose the merge operation and in the next dialog i pick the master file from the list.

I cannot replicate this, steps I tried:

1) Open editor
2) Click file1.html
3) Click file2.html
4) Right click and select Merge files
5) Click OK
6) Files are merged

If you have a specific ebook for which it is failing, attach the file,
and also describe exactly which html files in the book you are trying to
merge.

 status invalid

Changed in calibre:
status: New → Invalid
edward.81 (edward-81) wrote :

I just made a clean epub and the error persist. I have also tried to install the git version without luck.
But from you comment, I don't see the part that ask the user to chose the master file from the selected files.

Kovid Goyal (kovid) wrote :

Your problem is caused by their being no tags in body. Run the Check
Book tool and it will tell you that. Fix that and you should be fine.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
edward.81 (edward-81) wrote :

Follow your suggestion i wrapped the text inside the body on p tags. The error still persist. I tried the same operation on a windows7 machine running calibre 2.49 x64 and the merge works.
This is the error that the merge operation raise on my Linux machine.
calibre, version 2.49.0.r74.g78fcc5c
ERROR: Unhandled exception: <b>AbortError</b>:The master file (&page1.html) must be one of the files being merged

calibre 2.49.0.r74.g78fcc5c isfrozen: False is64bit: True
Linux-4.4.0-mainline-x86_64-with-glibc2.2.5 Linux ('64bit', '')
('Linux', '4.4.0-mainline', '#1 SMP PREEMPT Mon Jan 11 15:37:58 CET 2016')
Python 2.7.11
Linux: ('', '', '')
Successfully initialized third party plugins: DeDRM
Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/gui2/tweak_book/boss.py", line 66, in ans
    return func(*args, **kwargs)
  File "/usr/lib/calibre/calibre/gui2/tweak_book/boss.py", line 1161, in merge_requested
    merge(current_container(), category, names, master)
  File "/usr/lib/calibre/calibre/ebooks/oeb/polish/split.py", line 480, in merge
    raise AbortError('The master file (%s) must be one of the files being merged' % master)
AbortError: The master file (&page1.html) must be one of the files being merged

Dont use the distro version of calibre, use the official binary from
http://calibre-ebook.com/download_linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments