Context menu of the individual books on Ubuntu 15:10 flawed

Bug #1534936 reported by Nikolaus Schneider on 2016-01-16
164
This bug affects 24 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Reported Version 2.49.0. The context menu of the individual books, such as the metadata is not accessible on Ubuntu 15:10

This is some incompatibility between Qt 5.5.1 and Ubuntu's default
window manager. It appears to only happen in Ubuntu. I cannot replicate
it in KDE, GNOME or qtile. Not much I can do about this, since it is not
a bug in calibre code. You can downgrade to the previous calibre release
which uses Qt 5.4.2 or just live with the bug until it is fixed in
Ubuntu, which will probably happen i a few months when they update the
version of Qt they ship with the OS to 5.5.1

Instructions for downgrading are ont he calibre linux download page.

 status invalid

Changed in calibre:
status: New → Invalid
pandaconqueso (pandaconqueso) wrote :

I have the same issue but using the arrow keys and enter does work in the menu.

Same here, it works with the arrow keys, so I can manage.

A weird thing is that is does not affect all menus, and the "Send to device" menu is only affected when a device is connected. Is there a difference it the way the different menus are built or used ?

Kovid Goyal (kovid) wrote :

Not that I know of.

Also affected in Ubuntu 16.04 with calibre 2.56.

Right clicking on any book the first menu looks fine but the submenus blink and are not clickable.

Using arrow keys and enter works fine, as pandaconqueso says.

Already in QT 5.5.1

Xfce on Xubuntu solves the problem. :-)
Am 10.05.2016 15:21 schrieb "elhombresinatributos" <email address hidden>:

> Also affected in Ubuntu 16.04 with calibre 2.56.
>
> Right clicking on any book the first menu looks fine but the submenus
> blink and are not clickable.
>
> Using arrow keys and enter works fine, as pandaconqueso says.
>
> Already in QT 5.5.1
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1540162).
> https://bugs.launchpad.net/bugs/1534936
>
> Title:
> Context menu of the individual books on Ubuntu 15:10 flawed
>
> Status in calibre:
> Invalid
>
> Bug description:
> Reported Version 2.49.0. The context menu of the individual books,
> such as the metadata is not accessible on Ubuntu 15:10
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1534936/+subscriptions
>

Kovid Goyal (kovid) wrote :

Setting the environment variable

CALIBRE_NO_NATIVE_MENUBAR=1

will also fix it.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released

Solved in 2.60

rpgmaker (justmc) wrote :

If this is really a duplicate of the #1591764 that I reported then no, this is not fixed in 2.60 for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers