Bulk Metadata editing - Series Number

Bug #1523253 reported by dickinson.graham@gmail.com on 2015-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hi,

Single Book Metadata editing supports a Series Number of eg. 20.01, which one who use for a Volume and Issue Number for a magazine such as Volume 20 Issue 01.

When bulk Metadata editing, the Series Number does not allow a decimal point so the same format of Series Number cannot be updated, incrementing the number and has to be added manually to each magazine in the series.

Kind regards,

Graham

I'm confused. As far as I know, the bulk metadata dialog does not allow
setting of series numbers at all. This is natural, since that dialog is
meant to apply the same value to all books, and that makes no sense for
series number. So I dont understand what you are asking for.

 status invalid

Changed in calibre:
status: New → Invalid

Hi Kovid,

Thanks for your rapid response...but I have to tell you that you are
confused.

Please see attached screen shot of bulk metadata editing dialogue. Please
note lowest line on screen shot that refers to Series:, Automatically
Numbering Books, Force Start With: fields. The Force Start With: field does
not accept the necessary decimal places.

This is the latest version of Calibre - 2.45 but this gap has been true for
all previous versions that I have used. Great product by the way and I am
managing a 7k plus book / magazine library with it. I have used the bulk
edit feature extensively to number series of magazines. It works fine for
for bulk numbering mags with single numbers eg. Numbers 151 to 201.
However, if you want to represent volume and number eg. 20.01 for Vol 20
Number 01 you can only do it with single metadata edit, not with bulk
edit. I want to number Volume 20 Numbers 01 to 06 for example but I cannot
type 20.01 into the Force Start With: field.

This is only a small thing but would move Calibre even closer to being a
perfect product.

I do know what I am talking about, honestly...I have worked in IT /
Application Development in various roles and companies for 30 odd years :-)

On 6 December 2015 at 18:09, Kovid Goyal <email address hidden> wrote:

> I'm confused. As far as I know, the bulk metadata dialog does not allow
> setting of series numbers at all. This is natural, since that dialog is
> meant to apply the same value to all books, and that makes no sense for
> series number. So I dont understand what you are asking for.
>
> status invalid
>
> ** Changed in: calibre
> Status: New => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1523253
>
> Title:
> Bulk Metadata editing - Series Number
>
> Status in calibre:
> Invalid
>
> Bug description:
> Hi,
>
> Single Book Metadata editing supports a Series Number of eg. 20.01,
> which one who use for a Volume and Issue Number for a magazine such as
> Volume 20 Issue 01.
>
> When bulk Metadata editing, the Series Number does not allow a decimal
> point so the same format of Series Number cannot be updated,
> incrementing the number and has to be added manually to each magazine
> in the series.
>
> Kind regards,
>
> Graham
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1523253/+subscriptions
>

--
Kind regards,

Graham Dickinson

Charles Haley (cbhaley) wrote :

@Kovid: my guess is that he is asking that the start value be arbitrary in the series index range, and that you add an arbitrary index increment value (box) in the same range that defaults to 1.

Changed in calibre:
status: Invalid → Confirmed

OK, now I see what you were saying.

Changed in calibre:
status: Confirmed → Invalid

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Correct. Please note that the bulk edit start field already allows an arbitrary start point eg. 151 and will count up in increments of 1 from there to the end of the selected books. What it can't do is count up in decimal .01 increments. Yet the single book metadata editor supports decimal values of format uu.dd

This is an inconsistency in my view.

Graham

Kovid Goyal (kovid) on 2015-12-06
Changed in calibre:
status: Invalid → Fix Released

Ok, cool...thank you.

This has all been a very rapid response from you guys. I wish members of my
support team responded this quickly :-)

Ciao.

On 6 December 2015 at 19:43, Kovid Goyal <email address hidden> wrote:

> OK, now I see what you were saying.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1523253
>
> Title:
> Bulk Metadata editing - Series Number
>
> Status in calibre:
> Invalid
>
> Bug description:
> Hi,
>
> Single Book Metadata editing supports a Series Number of eg. 20.01,
> which one who use for a Volume and Issue Number for a magazine such as
> Volume 20 Issue 01.
>
> When bulk Metadata editing, the Series Number does not allow a decimal
> point so the same format of Series Number cannot be updated,
> incrementing the number and has to be added manually to each magazine
> in the series.
>
> Kind regards,
>
> Graham
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1523253/+subscriptions
>

--
Kind regards,

Graham Dickinson

I've already implemented support for non-integer start points. Adding an
extra control for customizable increments as well, is not wortht he
effort for me, patches are welcome.

I don't think you need an extra control. Just that the current bulk edit
'force start with' control supports uuu.dd format and counts in single
increments from the lowest significant digit. Would need some logic wrapped
around it of course.
Just my view. If you don't want to do it... so be it... I will keep doing
my magazine collection manually.

On Sun, 6 Dec 2015 20:05 Kovid Goyal <email address hidden> wrote:

> I've already implemented support for non-integer start points. Adding an
> extra control for customizable increments as well, is not wortht he
> effort for me, patches are welcome.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1523253
>
> Title:
> Bulk Metadata editing - Series Number
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Hi,
>
> Single Book Metadata editing supports a Series Number of eg. 20.01,
> which one who use for a Volume and Issue Number for a magazine such as
> Volume 20 Issue 01.
>
> When bulk Metadata editing, the Series Number does not allow a decimal
> point so the same format of Series Number cannot be updated,
> incrementing the number and has to be added manually to each magazine
> in the series.
>
> Kind regards,
>
> Graham
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1523253/+subscriptions
>

Awesome!

On Sun, 6 Dec 2015 20:01 Kovid Goyal <email address hidden> wrote:

> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Invalid => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1523253
>
> Title:
> Bulk Metadata editing - Series Number
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Hi,
>
> Single Book Metadata editing supports a Series Number of eg. 20.01,
> which one who use for a Volume and Issue Number for a magazine such as
> Volume 20 Issue 01.
>
> When bulk Metadata editing, the Series Number does not allow a decimal
> point so the same format of Series Number cannot be updated,
> incrementing the number and has to be added manually to each magazine
> in the series.
>
> Kind regards,
>
> Graham
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1523253/+subscriptions
>

Oh well, I had ten minutes while waiting for Qt to compile, so here you
go: https://github.com/kovidgoyal/calibre/commit/2e765455f558736f2f11fef6a24361f509cef67d

Thanks Kovid.
Not sure I'm qualified to QA your code. But it looks pretty impressive for
10 mins work.
I really look forward to the next release. :-)

Krgrds, Graham

Sent from my Android
On 6 Dec 2015 20:45, "Kovid Goyal" <email address hidden> wrote:

> Oh well, I had ten minutes while waiting for Qt to compile, so here you
> go:
> https://github.com/kovidgoyal/calibre/commit/2e765455f558736f2f11fef6a24361f509cef67d
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1523253
>
> Title:
> Bulk Metadata editing - Series Number
>
> Status in calibre:
> Fix Released
>
> Bug description:
> Hi,
>
> Single Book Metadata editing supports a Series Number of eg. 20.01,
> which one who use for a Volume and Issue Number for a magazine such as
> Volume 20 Issue 01.
>
> When bulk Metadata editing, the Series Number does not allow a decimal
> point so the same format of Series Number cannot be updated,
> incrementing the number and has to be added manually to each magazine
> in the series.
>
> Kind regards,
>
> Graham
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1523253/+subscriptions
>

Hi Kovid,

Had to rebuild my PC (Windows 10 issue after upgrade) so only just installed 2.46 now. Works great! Thanks very much.

Kind regards,

Graham.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers