Edit custom series resets series index to 1

Bug #1519599 reported by JP on 2015-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

Batch metadata search/replace of a custom series field resets the index to 1 on every entry.

Ex: #series2 column with entries Walkabout [1], Walkabout [2], Walkabout [3]

Search field: #series2
Search for: Walk
Replace with: Walking

Expected results: Walkingabout [1], Walkingabout [2], Walkingabout [3]
ACTUAL results: Walkingabout [1], Walkingabout [1], Walkingabout [1]

This works fine on the build int default Series column.
The custom columns for series, however, have this problem every time I've tried. I obviously avoid this now. When there are 30 entries, that gets a bit tough to redo...especially with entries that are non-integers such as 2.5. Those are not remembered as easily or automatic.

JP (jecilop) wrote :

Disregard the typo right bracket on results.
It is ], not }.
I cannot edit the original post.

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Eli Schwartz (eschwartz) wrote :

> Disregard the typo right bracket on results.
> It is ], not }.
> I cannot edit the original post.

I just fixed it, editing works fine.

You can only edit the original description, though -- not comments.
It's the round yellow icon with the pencil in it, in the upper right corner of the description box.

description: updated
Charles Haley (cbhaley) wrote :

Kovid: as you can see in the commit the problem is in db.cache.set_field. I fixed it by using the custom series index if there is one. I don't think that this change has any undesirable side effects but I am not as familiar with the new db as I should be.

Changed in calibre:
status: Triaged → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers