Logic custom columns NOT copying from one library to another

Bug #1516880 reported by JP on 2015-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

I have a Calibre Mobile Read forum here that shows the problem and tests. You may find it helpful. I will post the LONG below it.
http://www.mobileread.com/forums/showthread.php?p=3207188#post3207188

This is long because I ran A LOT of tests so to some degree it includes the train of thought as I did it. The simple summary is the bug title. It doesn't matter if they are existing libraries or completely new libraries that were NOT created by copying an existing structure.

I'm currently on 2.44 and Wdws 7. My initial problem of column views not saving in my primary library has been around for quite awhile. This problem as just discovered as I just started doing more custom, logic columns.

FIRST INQUIRY:
What would keep a custom column that is based on other columns from copying into a new library?

I created a new library and copied the structure of the current.
I then took a section of books and copied them to the new one. This included multiple custom columns, 2 of which are based on info in other columns.
Only one of my custom columns (the latest only recently created) did not copy. I had to recreate it in the new library (which means restarts...grrr...).

Any "missing column" notification windows were checked off when I copied the files to create my test library so that couldn't be it.

How can this happen

FURTHER TESTS:
....................."Create a NEW library. be sure to tick 'use existing structure'

Then us Copy To Library to move those books from the one that it was missing from to the NEW one. that should do it.".............

Yes, as noted (copied the structure of the original "use existing structure", boxed checked when creating), these are the steps I took. That's why it's odd.

I just tried it again with a newer custom column based off another (ie, a logical one) and went ahead and made another test column of text format just to see what would happen. Again, the logic column is NOT copying. It's not even popping up to let me know it doesn't exist in the other to give me the option to check the box to add it. However, the text column does.

Curious, I just tried it the opposite direction from the new library (existing structure copied) to the old existing one after adding new columns. That same exact problem exists in that direction.

The purpose of the new was to test a previous thread I have posted a few weeks back where the existing on has not been saving my column views upon exit. I have to hid columns again and rearrange them everytime. I did not have to change my column views for a long time. It was suggested that I have a corrupt database although everything else is fine. I can add new stuff and delete the old with no problem, but positioning isn't staying. However, it is working in other libraries. The suggestion was to try as I've noted. The new one does hold the column views.
It's is also worth noting that these are the first new logic columns I've created in a long time. The original two ARE copying without problems.
I need all of this working for other library management anyhow, especially if I have to redo my original large library and copy files over to a new directory and thus create a new, hopefully-not-corrupt database assuming that's the column view issue.

The only other test I have before inquiring as to a buggy state is to create a NEW library from scratch, add an entry and new logic column, and then try to copy that new info to another library to see if it works.....So now this is done...Fresh..no structure copied...
I just tried it....THE SAME PROBLEM exists...
COMPLETELY NEW LIBRARY.
The column views do hold in the new, fresh library so the view problem is unique to my original, LARGE library.
Created a text column and a logic column in the new, fresh library.
Tried to copy into the other test that was created with the copied structure.
The only option popped up was the text column..nothing about the logic column. SO THAT ISN"T WORKING.
Tried another NEW, fresh library to see if it would copy there without issue.

Again, NO LOGIC CUSTOM COLUMNS are NOT COPYING to another library whether they are new or old or the library is from a copied structure or completely new.

This last test was two completely new libraries with completely new logic columns and text custom columns. Only the text custom columns popped up as "not existing in the destination library" to give me the checkbox to choose them.
Looking at the list of all columns, visible or not, in the destination library also proves they are not there.

So unless you or someone else knows something, I have to wonder if something changed in an update.

This is a longer than expected reply, but I ended up running the gammut of test to ensure I wasn't missing anything I can think of and give a comparison for someone else to test or bug check.

Has anyone tested copying a logic column to another library lately?

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
JP (jecilop) wrote :

I've included a zip of one of the completely new libraries. It has one entry with at least one logic column called TestNEWLOGIC.

Charles Haley (cbhaley) wrote :

Composite columns were specifically excluded from a copy. I removed that exclusion.

Note that because the templates can vary, there is no guarantee that composite column A in library 1 will produce the same answer as column A in library 2.

Changed in calibre:
status: Triaged → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers