Edit Book: CheckBook and identifiers

Bug #1498207 reported by arspr on 2015-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hi Kovid,

In one book, Check Book has given me the following error:
+The OPF has no unique identifier.

OK, then I press "Auto-generate a unique identifier" and
<package xmlns="http://www.idpf.org/2007/opf" unique-identifier="58aff2db-721d-4478-a59c-c5f288971da3" version="2.0">
AND
<dc:identifier id="58aff2db-721d-4478-a59c-c5f288971da3" opf:scheme="uuid">58aff2db-721d-4478-a59c-c5f288971da3</dc:identifier>
are created.

The problem is that if I re-run Check Book, then I get the following warning:

Invalid id: 58aff2db-721d-4478-a59c-c5f288971da3    [OPS/0-package.opf]

Because "The id 58aff2db-721d-4478-a59c-c5f288971da3 is not a valid id. IDs must start with a letter ([A-Za-z]) and may be followed by any number of letters, digits ([0-9]), hyphens ("-"), underscores ("_"), colons (":"), and periods ("."). This is to ensure maximum compatibility with a wide range of devices."

So shouldn't you create a valid id in the first place?

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers