virtual libraries fail on web access

Bug #1446282 reported by tom miller on 2015-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Perhaps I am 'over using' virtual libraries, but with a virtual library count of 44, the web access crashes with a stack trace.

The trace is listed below from a screen shot.

I am running calibre version 2.25 on a Mac OS X version 10.10.3 (14D136).

tom miller (rellim-j-mot) wrote :
Charles Haley (cbhaley) wrote :

@Kovid: experimentation shows that the problem is related to the "Max ungrouped items" setting. If you have more VLs than that setting, something goes south. I haven't worked out exactly what.

I haven’t set the max ungrouped items. I have reduced the number of VLs
under 40, but it still fails.

On Mon, Apr 20, 2015 at 3:44 PM, Charles Haley <email address hidden>
wrote:

> @Kovid: experimentation shows that the problem is related to the "Max
> ungrouped items" setting. If you have more VLs than that setting,
> something goes south. I haven't worked out exactly what.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1446282
>
> Title:
> virtual libraries fail on web access
>
> Status in calibre: e-book management:
> New
>
> Bug description:
> Perhaps I am 'over using' virtual libraries, but with a virtual
> library count of 44, the web access crashes with a stack trace.
>
> The trace is listed below from a screen shot.
>
> I am running calibre version 2.25 on a Mac OS X version 10.10.3
> (14D136).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1446282/+subscriptions
>

--
"Whenever you do not know what to do, do not do it." C.H. Spurgeon

Charles Haley (cbhaley) wrote :

And what exactly is the value in the box Preferences / Sharing over the net / Max. ungrouped items? And what happens if you set that vallue to, for example, 100?

tom miller (rellim-j-mot) wrote :

Idiot alert!!!

I had set it, it was at 32. I put it up to 100 and the problem went away.

Now we need to figure out how to fix my memory...

Thanks for your help!

tm

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers