Spell check flags html tags in metadata

Bug #1441925 reported by Bruce Stevenson on 2015-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre V2.23 and earlier
Windows 8.0

Book Editor
If metadata book descriptions contain formatting (as mine usually do), the Spell Check incorrectly reports errors in the html tags.

For example, my most recent book has 2 div, 4 h3, 2 i (italics) and 1 br tags reported as spelling errors. Not errors in the fields marked by those tags, rather the tags themselves. These errors are confined to the Content.opf: description field. Also of interest is the fact the p (para) tags, also present, are not reported.

In spell-checking, could other valid html tags also be filtered out of the description as it seems the para tags already are? For consideration...

Cheers
Bruce

I cannot reproduce this, HTML tag definitions are ignored in the
dc:description field of the OPF file for me. If you hvae a particular
book where this occurs feel free to re-open this ticket and upload it.

 status invalid

Changed in calibre:
status: New → Invalid
Bruce Stevenson (bruceee) wrote :

Have created a little epub which shows the problem. (Attached)

Add the book into a calibre library, open it in the book editor and run the Spell Check.

For me, about 20 errors show, most coming from the HTML tags.

Cheers, Bruce

Changed in calibre:
status: Invalid → New
Bruce Stevenson (bruceee) wrote :

Also, make sure you don't have the tags listed in a user dictionary. I just found an h3 and a br in one of mine!

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers