Icons not showing

Bug #1436690 reported by Tanja on 2015-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

I need a lot of icons in my library, but when I add more than 139 to the same category with different conditions, it stops showing them all. Is it something you can fix?

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) wrote :

If you are saying that you cannot put more than 139 icons on one column, then you have probably run into a limit of the Qt toolkit that calibre uses. The toolkit cannot create an icon wider than 32767 pixels (which of course is *much* wider than any screen I know of). The individual icons for a column are combined together into one displayable icon. If the result is wider than 32767 pixels then the icons will be displayed incorrectly. This will not change. For standard-sized icons (128x128) the maximum number of icons per column is 252. If your icons are wider than 128 pixels then the maximum will go down.

You cannot see more icons in a column than will display in the width of the column. There is no scrolling inside a column. That said, seeing 139 icons in one column would require a screen more than 18,000 pixels wide so I suspect this is not what you are saying.

If you are saying that only 139 icons can be displayed across all columns then I cannot repeat this. My test successfully displays 492 icons.

If you are saying that there is a small limit to the number of rules/conditions one can apply then I cannot repeat this. My test uses 10 'composed' rules to generate an icon set for a column, and all the appropriate icons are displayed. I know of no reason other than complexity that one cannot use many more rules than 10.

Changed in calibre:
status: Triaged → Invalid
Tanja (tanjamuse) wrote :

Would it help if I attached my metadata.db?

Charles Haley (cbhaley) wrote :

OK, but in addition to the metadata.db I will need the icon files in the cc_icons folder inside your calibre configuration folder. Best would be to put the db and the icons folder into a single zip file.

I will also need to know what is not behaving correctly, for example a single book where icon X should be displayed in column Y but is not.

I hope this is what you've asked for:

For some reason it reaches Radagast and then it stops working. I've added a
couple of stories.

If you need anything else, let me know.

2015-03-26 12:30 GMT+01:00 Charles Haley <email address hidden>:

> OK, but in addition to the metadata.db I will need the icon files in the
> cc_icons folder inside your calibre configuration folder. Best would be
> to put the db and the icons folder into a single zip file.
>
> I will also need to know what is not behaving correctly, for example a
> single book where icon X should be displayed in column Y but is not.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1436690
>
> Title:
> Icons not showing
>
> Status in calibre: e-book management:
> Invalid
>
> Bug description:
> I need a lot of icons in my library, but when I add more than 139 to
> the same category with different conditions, it stops showing them
> all. Is it something you can fix?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1436690/+subscriptions
>

Charles Haley (cbhaley) wrote :

I don't know what you mean "it reaches Radagast and then it stops working". What stops working? What will it show if it works?

Tanja (tanjamuse) wrote :

If it works it should show the attached image in I7 Column for the
following story: *Remus's Special Friends*.

2015-03-26 13:23 GMT+01:00 Charles Haley <email address hidden>:

> I don't know what you mean "it reaches Radagast and then it stops
> working". What stops working? What will it show if it works?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1436690
>
> Title:
> Icons not showing
>
> Status in calibre: e-book management:
> Invalid
>
> Bug description:
> I need a lot of icons in my library, but when I add more than 139 to
> the same category with different conditions, it stops showing them
> all. Is it something you can fix?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1436690/+subscriptions
>

Charles Haley (cbhaley) wrote :

The problem is caused by one of your icon files, "Ramandue's Daughter.png", having an apostrophe in its name. This apostrophe causes the coloring system to fail.

Fix it by removing the apostrophe from the file name in cc_icons, starting calibre, going to preferences / use and feel / column icons, and changing the two rules that use the name "Ramandue's Daughter.png" to instead use the name "Ramandues Daughter.png".

Tanja (tanjamuse) wrote :

Thank you soooooo much. I'm sorry for all the troubles.

2015-03-26 14:15 GMT+01:00 Charles Haley <email address hidden>:

> The problem is caused by one of your icon files, "Ramandue's
> Daughter.png", having an apostrophe in its name. This apostrophe causes
> the coloring system to fail.
>
> Fix it by removing the apostrophe from the file name in cc_icons,
> starting calibre, going to preferences / use and feel / column icons,
> and changing the two rules that use the name "Ramandue's Daughter.png"
> to instead use the name "Ramandues Daughter.png".
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1436690
>
> Title:
> Icons not showing
>
> Status in calibre: e-book management:
> Invalid
>
> Bug description:
> I need a lot of icons in my library, but when I add more than 139 to
> the same category with different conditions, it stops showing them
> all. Is it something you can fix?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1436690/+subscriptions
>

Charles Haley (cbhaley) wrote :

Fix submitted to automatically remove apostrophes from newly-added column icon files.

Changed in calibre:
status: Invalid → Fix Committed

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers