Get Books does not return results from Amazon US

Bug #1406040 reported by casfindad on 2014-12-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
John Schember

Bug Description

Pressing Get books and searching for author or title does not return any results for Amazon US. I am using Calibre 2.14 on Linux.

Changing the component for this bug.

 assignee user-none
 status triaged

Changed in calibre:
assignee: nobody → John Schember (user-none)
status: New → Triaged
casfindad (caseyfmail-linux) wrote :

Just noticed that the Project Gutenberg store plugin also fails to return hits under "Get books". eBooks.com, ManyBooks and Feedbooks all work.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Triaged → Fix Released

Project Gutenberg works fine for me. For example:

title:pride prejudice
author:austen

returns two results from PG

Wow, nice work! I just began working with Calibre today, and I'm very, very
impressed. Even the introductory video was very polished. It looks like you
were running Linux with a KDE desktop. If you have a chance, please let me
know what screen recording software you use and recommend. I'm looking for
a good one to use in Linux and/or Mac.

Cheers,

Casey

Casey M. Finnerty, Ph. D.
Winona, MN
On Dec 27, 2014 11:10 PM, "Kovid Goyal" <email address hidden> wrote:

> Fixed in branch master. The fix will be in the next release. calibre is
> usually released every Friday.
>
> status fixreleased
>
> ** Changed in: calibre
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1406040
>
> Title:
> Get Books does not return results from Amazon US
>
> Status in calibre: e-book management:
> Fix Released
>
> Bug description:
> Pressing Get books and searching for author or title does not return
> any results for Amazon US. I am using Calibre 2.14 on Linux.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1406040/+subscriptions
>

I use my own script for screencasting, that makes use of various tools
(ffmpeg, xwininfo, qtile)

If I replicate your search, I get no results from PG (nor ManyBooks).

Also, Amazon Kindle US is now returning results.

Finally, if I delete author: austen, I get more results from Amazon Kindle
US. For example, free editions are only returned from Amazon Kindle if I
delete the author search.

On Sat, Dec 27, 2014 at 11:15 PM, Kovid Goyal <email address hidden>
wrote:

> Project Gutenberg works fine for me. For example:
>
> title:pride prejudice
> author:austen
>
> returns two results from PG
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1406040
>
> Title:
> Get Books does not return results from Amazon US
>
> Status in calibre: e-book management:
> Fix Released
>
> Bug description:
> Pressing Get books and searching for author or title does not return
> any results for Amazon US. I am using Calibre 2.14 on Linux.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1406040/+subscriptions
>

--
Casey M. Finnerty, Ph. D.
Winona, MN
USA

casfindad (caseyfmail-linux) wrote :

FYI, I think the issue is websites being down. The PG website appears down
at the moment.

On Sat, Dec 27, 2014 at 11:48 PM, Casey Finnerty <email address hidden>
wrote:

> If I replicate your search, I get no results from PG (nor ManyBooks).
>
> Also, Amazon Kindle US is now returning results.
>
> Finally, if I delete author: austen, I get more results from Amazon Kindle
> US. For example, free editions are only returned from Amazon Kindle if I
> delete the author search.
>
> On Sat, Dec 27, 2014 at 11:15 PM, Kovid Goyal <email address hidden>
> wrote:
>
>> Project Gutenberg works fine for me. For example:
>>
>> title:pride prejudice
>> author:austen
>>
>> returns two results from PG
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1406040
>>
>> Title:
>> Get Books does not return results from Amazon US
>>
>> Status in calibre: e-book management:
>> Fix Released
>>
>> Bug description:
>> Pressing Get books and searching for author or title does not return
>> any results for Amazon US. I am using Calibre 2.14 on Linux.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/calibre/+bug/1406040/+subscriptions
>>
>
>
>
> --
> Casey M. Finnerty, Ph. D.
> Winona, MN
> USA
>

--
Casey M. Finnerty, Ph. D.
Winona, MN
USA

Amaonz US now works because fixes to Get Books plugins are automatically propagated

Kovid Goyal (kovid) wrote :

The problem of US Amazon not working for author:austen is now fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers