Deleting a book both in device and library makes cursor jump

Bug #1404629 reported by Raúl Núñez de Arenas Coronado on 2014-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre 2.14 64bit on Windows 8.1 64bits, although this affects older releases, too.

This doesn't seem to be the same bug as https://bugs.launchpad.net/calibre/+bug/1051135

Steps to reproduce:
- Connect a device (in my case I'm using a Kindle Touch, I don't know if that is important or not) containing some books which were transferred previously from the library. So, these books are present both in the device AND the library.

- Sort library by "On Device" column, so the books present both in device and library are shown on top of the library.

- Delete one book from the device, but when asked choose to delete it from "Library and Device".

EXPECTED RESULT: the book immediately below the deleted book is selected.

WHAT HAPPENS INSTEAD: a random book on the library is selected. I bet is not "random", but probably the book above or below the deleted book according to some sorting key I can't determine (probably Title). So far, and since I can't determine which book gets selected and by which reason, to me the selection is random.

Probably tomorrow I can perform some tests to give you additional information if you want me to.

Thanks a lot for Calibre!

After some tests, looks plausible that the sorting key I couldn't determine is book title.

Also, deleting a file from ONLY the device, when showing the books from ONLY the device (on device memory, I mean, using the button showing a Kindle), doesn't select any other book. Maybe the problem is related to this :?

Again, thanks, and if you want me to carry more tests, just ask.

I've carried more tests and looks like the "random" key is the last sorting key used to sort the entire library, before sorting by "On Device" column.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Hybridtupel (hybridtupel) wrote :

This bug should be fixed by now (v 2.23)? I have a bug similar to this.
- Connect device
- Go to Device view
- Select and delete a book (on the device)
- The selected book is deleted but afterwards always the first book is selected which often lets the list jump to the top.
- I assume here also the next / previous book should be selected

Because of the way deleting work on devices (it is an asynchronous
process and involves refreshing the entire view) this is not easy to fix
in the device view. It was however fixed in the main library view (from
where also you can delete books from the device).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers