Icon not showing on Comments custom column

Bug #1404234 reported by Better Red on 2014-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Version 2.13 was updated to highlight custom column Long Text cells when they were current.

But, if the column has a column icon, the icon is not shown. Long Text columns 'need' an 'Is Set' icon because a the contents of a Long Text cell are not always displayable - e.g. if the cell contains an image.

This is a regression issue. Custom Long Text columns with an 'Is Set' icon worked fine prior to version 2.0 - the icon displayed if the cell was not empty and the cell was highlighted when current.

I guess the icon is more important to me than the highlighting when current, but I'd rather have both.

BR

I know of no (resonable) way to support icons on comment type columns.
The support for it in the previous releases was broken, in that it would work
if there was no actual content being rendered in the cell, but, if there was,
the content would be rendered on top of the icon, instead of beside it,
as with all other columns.

If you want to display an "is set" type icon, display it in another
column, using a template, which you can place right next to the comments
type column, to give you almost the same thing.

 status wontfix

Changed in calibre:
status: New → Won't Fix
Better Red (urbanetiger) wrote :

"The support for it in the previous releases was broken, in that it would work
if there was no actual content being rendered in the cell, but, if there was,
the content would be rendered on top of the icon, instead of beside it,
as with all other columns."

That was not the case in 1.48 - see image

Better Red (urbanetiger) wrote :

And here is a library you can test with -

FWIW, I don't normally display the Note contents in the book list, just the icon

Kovid Goyal (kovid) wrote :

If all you want to do is display an indication that the column is
populated, then simply use a custom column with an appropriate template.

And the column in your screenshot only works because it happens that the
margins of the document are sufficient that the content does not overlay
the icon. That is not generally the case.

Kovid Goyal (kovid) wrote :

Never mind, I figured it out :)

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers