Autosuggest in text fields eats keystrokes from On-Screen Keyboard on Windows

Bug #1385586 reported by Vasyl on 2014-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

When using On-Screen Keyboard app on Windows to enter text (title, author, publisher, etc) the auto suggest dropdown may appear on keystroke and the next keystroke will close it without entering the key. This makes using OSK very tedious as many keys have to be pressed twice. The issue is 100% consistent and repeatable.
It is a regression with Qt update - the OSK worked much better in older versions. The bug is verified in current 2.7 on Win7/64.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers