Unicode Conversion on Amazon after Release 2.x

Bug #1364961 reported by Vermeulen, Stefan on 2014-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

After migrating to the new 2.x Version (still in the current), the german characters are translated wrong when loading Metadata for example from Amazon (in fact they seem to be read as 2 Byte Unicode, so one character results in 2 strange char's in Display).

There have been no changes to metadata retrieval in 2.x
If metadata is being incorrectly retrieved for some book, post the title
and author of that book.

 status incomplete

Changed in calibre:
status: New → Incomplete
Vermeulen, Stefan (calibre-k) wrote :

isbn:9783439777057, author is "Höfling, Helmut", not "Hã¶fling, Helmut"
If you need more examples, just tell. Sometimes it's also occring in comment (but not with this one), often also in publisher (verlag).
Thank you!

Kovid Goyal (kovid) wrote :

This is caused by a bug in amazon.de

Their HTML pages contain two charset declarations, one in HTML 4 format
for iso-8859-1 and one in html 5 format for utf-8.

I will add a workaround for it.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Vermeulen, Stefan (calibre-k) wrote :

Thank you very much! That was great - sooo fast!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers