The number zero doesn't appear

Bug #1363076 reported by Dave French on 2014-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

I've created a column that uses numbers. Previous to calibre version 2.0 if I inserted the number 0 (zero) it would stay. Since version 2.0 and now 2.1, if I try to insert the number zero in the cell just stays blank. This is using both the pre-made column type of "integers" and "floating point numbers".
Running windows 7 with calibre porable version 2.1

Dave French (bulldog001) on 2014-08-29
description: updated

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Kovid Goyal (kovid) wrote :

@Charles: I will take a look at this, I'm assigning it to you just so
you can take a look if needed.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Triaged → Fix Released
Charles Haley (cbhaley) wrote :

@kovid: the problem is in gui2.library.models.py line 983. That line is converting a zero to an empty string, probably because value == 0 so is false.

Charles Haley (cbhaley) wrote :

Ahh ... the delays in getting emails from the tracking system bites again. I didn't see that you were looking at it until I had written my post.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers